ipq40xx: add support for the ZyXEL NBG6617
[openwrt/openwrt.git] / target / linux / ipq40xx / image / Makefile
index c13516e6dcb71ae650e69a9a2fe0b525f5ba3ee6..d1ee1004fddce6cf6007259229d8eee5b5b2ea3b 100644 (file)
@@ -1,6 +1,8 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
+DEVICE_VARS += RAS_BOARD RAS_ROOTFS_SIZE RAS_VERSION
+
 define Device/Default
        PROFILES := Default
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
@@ -38,8 +40,8 @@ define Device/DniImage
        NETGEAR_BOARD_ID :=
        NETGEAR_HW_ID :=
        IMAGES := factory.img sysupgrade.bin
-       IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | netgear-dni
-       IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakeroot-hdr | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
+       IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | netgear-dni
+       IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
 endef
 DEVICE_VARS += NETGEAR_BOARD_ID NETGEAR_HW_ID
 
@@ -51,7 +53,6 @@ define Device/8dev_jalapeno
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        DEVICE_TITLE := 8devices Jalapeno
-       DEVICE_PACKAGES := ath10k-firmware-qca4019 ipq-wifi-8dev_jalapeno
 endef
 TARGET_DEVICES += 8dev_jalapeno
 
@@ -71,7 +72,7 @@ define Device/asus_rt-ac58u
 #      string and call it a day.... Yeah, we do the latter!
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
        IMAGES := sysupgrade.bin
-       DEVICE_PACKAGES := ipq-wifi-asus_rt-ac58u kmod-usb-ledtrig-usbport
+       DEVICE_PACKAGES := kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += asus_rt-ac58u
 
@@ -81,9 +82,12 @@ define Device/avm_fritzbox-4040
        BOARD_NAME := fritz4040
        DEVICE_TITLE := AVM Fritz!Box 4040
        IMAGE_SIZE := 29753344
-       IMAGES = sysupgrade.bin
+       UBOOT_PATH := $$(BIN_DIR)/u-boot-fritz4040/uboot-fritz4040.bin
+       UBOOT_PARTITION_SIZE := 524288
+       IMAGES = eva.bin sysupgrade.bin
+       IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-avm_fritzbox-4040 fritz-tffs fritz-caldata u-boot-fritz4040
+       DEVICE_PACKAGES := fritz-tffs fritz-caldata u-boot-fritz4040
 endef
 TARGET_DEVICES += avm_fritzbox-4040
 
@@ -97,7 +101,7 @@ define Device/compex_wpj428
        KERNEL_SIZE := 4096k
        IMAGES = sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019 kmod-gpio-beeper
+       DEVICE_PACKAGES := kmod-gpio-beeper
 endef
 TARGET_DEVICES += compex_wpj428
 
@@ -110,7 +114,6 @@ define Device/glinet_gl-b1300
        IMAGE_SIZE := 26624k
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel |append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ipq-wifi-glinet_gl-b1300
 endef
 TARGET_DEVICES += glinet_gl-b1300
 
@@ -121,7 +124,7 @@ define Device/meraki_mr33
        PAGESIZE := 2048
        DEVICE_TITLE := Cisco Meraki MR33
        IMAGES = sysupgrade.bin
-       DEVICE_PACKAGES := -swconfig ipq-wifi-meraki_mr33 ath10k-firmware-qca9887
+       DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887
 endef
 TARGET_DEVICES += meraki_mr33
 
@@ -129,7 +132,6 @@ define Device/netgear_ex61x0v2
        $(call Device/DniImage)
        KERNEL_SIZE := 3080192
        DEVICE_DTS_CONFIG := config@4
-       DEVICE_PACKAGES := ath10k-firmware-qca4019 ipq-wifi-netgear_ex61x0v2
        NETGEAR_BOARD_ID := EX6150v2series
        NETGEAR_HW_ID := 29765285+16+0+128+2x2
 endef
@@ -159,10 +161,26 @@ define Device/openmesh_a42
        IMAGES = factory.bin sysupgrade.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019 uboot-envtools
+       DEVICE_PACKAGES := uboot-envtools
 endef
 TARGET_DEVICES += openmesh_a42
 
+define Device/openmesh_a62
+       $(call Device/FitImageLzma)
+       DEVICE_DTS := qcom-ipq4019-a62
+       DEVICE_DTS_CONFIG := config@om.a62
+       BLOCKSIZE := 64k
+       DEVICE_TITLE := OpenMesh A62
+       KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
+       IMAGE_SIZE := 15552k
+       IMAGES = factory.bin sysupgrade.bin
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A62
+       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := ath10k-firmware-qca9888 uboot-envtools
+endef
+
+TARGET_DEVICES += openmesh_a62
+
 define Device/qcom_ap-dk01.1-c1
        DEVICE_TITLE := QCA AP-DK01.1-C1
        BOARD_NAME := ap-dk01.1-c1
@@ -173,7 +191,6 @@ define Device/qcom_ap-dk01.1-c1
        $(call Device/FitImage)
        IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | pad-to $$$${KERNEL_SIZE} | append-rootfs | pad-rootfs | append-metadata
-       DEVICE_PACKAGES := ath10k-firmware-qca4019
 endef
 TARGET_DEVICES += qcom_ap-dk01.1-c1
 
@@ -190,4 +207,35 @@ define Device/qcom_ap-dk04.1-c1
 endef
 TARGET_DEVICES += qcom_ap-dk04.1-c1
 
+define Device/zyxel_nbg6617
+       $(call Device/FitImageLzma)
+       DEVICE_DTS := qcom-ipq4018-nbg6617
+       DEVICE_TITLE := ZyXEL NBG6617
+       ROOTFS_SIZE := 24960k
+       RAS_BOARD := NBG6617
+       RAS_ROOTFS_SIZE := 19840k
+       RAS_VERSION := "$(VERSION_DIST) $(REVISION)"
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       IMAGES := sysupgrade.bin factory.bin
+#      The ZyXEL firmware allows flashing thru the web-gui only when the rootfs is
+#      at least as large as the one of the initial firmware image (not the current
+#      one on the device). This only applies to the Web-UI, the bootlaoder ignores
+#      this minimum-size. However, the larger image can be flashed both ways.
+       IMAGE/factory.bin := append-rootfs | pad-rootfs | check-size $$$$(ROOTFS_SIZE) | make-ras
+       IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | check-size $$$$(ROOTFS_SIZE) | sysupgrade-tar rootfs=$$$$@ | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-zyxel_nbg6617 uboot-envtools
+endef
+TARGET_DEVICES += zyxel_nbg6617
+
+define Device/zyxel_wre6606
+       $(call Device/FitImage)
+       DEVICE_TITLE := ZyXEL WRE6606
+       DEVICE_DTS_CONFIG := config@4
+       DEVICE_DTS := qcom-ipq4018-wre6606
+       DEVICE_PACKAGES := ipq-wifi-zyxel_wre6606
+       IMAGES := sysupgrade.bin
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+endef
+TARGET_DEVICES += zyxel_wre6606
+
 $(eval $(call BuildImage))