ipq40xx: add support for YYeTs LE1
[openwrt/staging/jow.git] / target / linux / ipq40xx / image / generic.mk
index 8fd7ab291531a16dc2dd8fe252f8bea6e98754fe..6dd4549f8df8575151b1f0d633cee1b2d6bba58e 100644 (file)
@@ -1122,6 +1122,20 @@ define Device/wallys_dr40x9
 endef
 TARGET_DEVICES += wallys_dr40x9
 
+define Device/yyets_le1
+       $(call Device/FitzImage)
+       DEVICE_VENDOR := YYeTs
+       DEVICE_MODEL := LE1
+       SOC := qcom-ipq4019
+       KERNEL_SIZE := 4096k
+       IMAGE_SIZE := 31232k
+       IMAGES += factory.bin
+       IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
+       DEVICE_PACKAGES := ipq-wifi-yyets_le1 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += yyets_le1
+
 define Device/zte_mf18a
        $(call Device/FitImage)
        DEVICE_VENDOR := ZTE