ipq40xx: fix image building for ZTE MF287 series
[openwrt/openwrt.git] / target / linux / ipq40xx / image / generic.mk
index 29778156df03565a5a77753f62e10b991c26614f..8fd7ab291531a16dc2dd8fe252f8bea6e98754fe 100644 (file)
@@ -1162,7 +1162,7 @@ define Device/zte_mf287_common
 #      exploit for the web interface
        IMAGES += factory.bin recovery.bin
        IMAGE/factory.bin  := append-ubi
-       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/openwrt-$$(BOARD)$$(if $$(SUBTARGET),-$$(SUBTARGET))-$$(DEVICE_NAME)-initramfs-zImage.itb rootfs=$$$$@ | append-metadata
+       IMAGE/recovery.bin := append-squashfs4-fakeroot | sysupgrade-tar kernel=$$$$(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE) rootfs=$$$$@ | append-metadata
 endef
 
 define Device/zte_mf287plus