ipq40xx: meraki: define DTB load address
[openwrt/openwrt.git] / target / linux / ipq40xx / image / generic.mk
index 78fa22c2345a09ce1d5338bf310d59a1adfa9232..907558302c70ddc06a9c51631ad718e1337b090d 100644 (file)
@@ -762,13 +762,13 @@ define Device/meraki_common
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        PAGESIZE := 2048
+       DEVICE_DTS_LOADADDR := 0x89000000
        DEVICE_PACKAGES := ath10k-firmware-qca9887-ct
 endef
 
 define Device/meraki_mr33
        $(call Device/meraki_common)
        DEVICE_MODEL := MR33
-       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr33
 
@@ -776,7 +776,6 @@ define Device/meraki_mr74
        $(call Device/meraki_common)
        DEVICE_MODEL := MR74
        DEVICE_DTS_CONFIG := config@3
-       DEFAULT := n
 endef
 TARGET_DEVICES += meraki_mr74