image: use helper function for size units
[openwrt/openwrt.git] / target / linux / ipq40xx / image / generic.mk
index 1757684a7c185be00f754ab4b90c5190bb7d685c..b4719033c0a54e8531207967286984359fdf1786 100644 (file)
@@ -68,7 +68,7 @@ define Build/mkmylofw_32m
 
        let \
                size="$$(stat -c%s $@)" \
-               pad="$(subst k,* 1024,$(BLOCKSIZE))" \
+               pad="$(call exp_units,$(BLOCKSIZE))" \
                pad="(pad - (size % pad)) % pad" \
                newsize='size + pad'; \
                $(STAGING_DIR_HOST)/bin/mkmylofw \