treewide: call check-size before append-metadata
[openwrt/staging/wigyori.git] / target / linux / ipq40xx / image / generic.mk
index 68e565594dadfc524097f4bda735052719634f43..9dee742eb4cd83b98b1de4e694ccfce838d546d7 100644 (file)
@@ -35,7 +35,7 @@ define Device/DniImage
        IMAGES += factory.img
        IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | netgear-dni
        IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | \
-               append-rootfs | pad-rootfs | append-metadata | check-size
+               append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 
 define Build/append-rootfshdr
@@ -106,7 +106,7 @@ define Device/8dev_habanero-dvk
        IMAGE_SIZE := 30976k
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
-       IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | check-size | append-metadata
 endef
 TARGET_DEVICES += 8dev_habanero-dvk
 
@@ -207,7 +207,7 @@ define Device/avm_fritzbox-4040
        UBOOT_PARTITION_SIZE := 524288
        IMAGES += eva.bin
        IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
-       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        DEVICE_PACKAGES := fritz-tffs fritz-caldata
 endef
 TARGET_DEVICES += avm_fritzbox-4040
@@ -822,7 +822,7 @@ define Device/zyxel_wre6606
        DEVICE_DTS_CONFIG := config@4
        SOC := qcom-ipq4018
        IMAGE_SIZE := 13184k
-       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
+       IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef
 TARGET_DEVICES += zyxel_wre6606