ipq40xx: add MikroTik wAP ac (RBwAPG-5HacD2HnD) support
[openwrt/staging/aparcar.git] / target / linux / ipq40xx / image / mikrotik.mk
index b2e8428e94224372445ac99d33fb47a279c0c274..d1f0829cd3f3d43d0e2a447847dac0058e0b030e 100644 (file)
@@ -62,3 +62,11 @@ define Device/mikrotik_sxtsq-5-ac
        DEVICE_PACKAGES := rssileds
 endef
 TARGET_DEVICES += mikrotik_sxtsq-5-ac
+
+define Device/mikrotik_wap-ac
+       $(call Device/mikrotik_nor)
+       DEVICE_MODEL := wAP ac
+       SOC := qcom-ipq4018
+       DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
+endef
+TARGET_DEVICES += mikrotik_wap-ac