ipq40xx: add ipqess ethernet driver
[openwrt/staging/chunkeey.git] / target / linux / ipq40xx / patches-4.19 / 720-ipqess.patch
diff --git a/target/linux/ipq40xx/patches-4.19/720-ipqess.patch b/target/linux/ipq40xx/patches-4.19/720-ipqess.patch
new file mode 100644 (file)
index 0000000..ba16b41
--- /dev/null
@@ -0,0 +1,30 @@
+--- a/drivers/net/ethernet/qualcomm/Kconfig
++++ b/drivers/net/ethernet/qualcomm/Kconfig
+@@ -15,6 +15,15 @@ config NET_VENDOR_QUALCOMM
+ if NET_VENDOR_QUALCOMM
++config IPQ_ESS
++      tristate "Qualcomm Atheros IPQ ESS support"
++      depends on OF
++      ---help---
++        This SPI protocol driver supports the Qualcomm Atheros QCA7000.
++
++        To compile this driver as a module, choose M here. The module
++        will be called qcaspi.
++
+ config QCA7000
+       tristate
+       help
+--- a/drivers/net/ethernet/qualcomm/Makefile
++++ b/drivers/net/ethernet/qualcomm/Makefile
+@@ -3,6 +3,9 @@
+ # Makefile for the Qualcomm network device drivers.
+ #
++obj-$(CONFIG_IPQ_ESS) += ipq_ess.o
++ipq_ess-objs := ipqess.o ipqess_ethtool.o
++
+ obj-$(CONFIG_QCA7000) += qca_7k_common.o
+ obj-$(CONFIG_QCA7000_SPI) += qcaspi.o
+ qcaspi-objs := qca_7k.o qca_debug.o qca_spi.o