kernel: update 3.14 to 3.14.18
[openwrt/openwrt.git] / target / linux / ipq806x / patches / 0002-ARM-msm-Remove-pen_release-usage.patch
index 72b6618e23b1d119598b89ab4b573dd526d51e6c..19eaae62e59b81b41a30b6b869ace183cdd4301b 100644 (file)
@@ -19,11 +19,9 @@ Signed-off-by: Kumar Gala <galak@codeaurora.org>
  4 files changed, 8 insertions(+), 101 deletions(-)
  delete mode 100644 arch/arm/mach-msm/headsmp.S
 
-diff --git a/arch/arm/mach-msm/Makefile b/arch/arm/mach-msm/Makefile
-index 8e307a1..721f27f 100644
 --- a/arch/arm/mach-msm/Makefile
 +++ b/arch/arm/mach-msm/Makefile
-@@ -19,7 +19,7 @@ obj-$(CONFIG_MSM_SCM) += scm.o scm-boot.o
+@@ -19,7 +19,7 @@ obj-$(CONFIG_MSM_SCM) += scm.o scm-boot.
  CFLAGS_scm.o :=$(call as-instr,.arch_extension sec,-DREQUIRES_SEC=1)
  
  obj-$(CONFIG_HOTPLUG_CPU) += hotplug.o
@@ -32,9 +30,6 @@ index 8e307a1..721f27f 100644
  
  obj-$(CONFIG_MACH_TROUT) += board-trout.o board-trout-gpio.o board-trout-mmc.o devices-msm7x00.o
  obj-$(CONFIG_MACH_TROUT) += board-trout.o board-trout-gpio.o board-trout-mmc.o board-trout-panel.o devices-msm7x00.o
-diff --git a/arch/arm/mach-msm/headsmp.S b/arch/arm/mach-msm/headsmp.S
-deleted file mode 100644
-index 6c62c3f..0000000
 --- a/arch/arm/mach-msm/headsmp.S
 +++ /dev/null
 @@ -1,39 +0,0 @@
@@ -77,11 +72,9 @@ index 6c62c3f..0000000
 -      .align
 -1:    .long   .
 -      .long   pen_release
-diff --git a/arch/arm/mach-msm/hotplug.c b/arch/arm/mach-msm/hotplug.c
-index 326a872..cea80fc 100644
 --- a/arch/arm/mach-msm/hotplug.c
 +++ b/arch/arm/mach-msm/hotplug.c
-@@ -24,33 +24,10 @@ static inline void cpu_leave_lowpower(void)
+@@ -24,33 +24,10 @@ static inline void cpu_leave_lowpower(vo
  
  static inline void platform_do_lowpower(unsigned int cpu)
  {
@@ -119,8 +112,6 @@ index 326a872..cea80fc 100644
  }
  
  /*
-diff --git a/arch/arm/mach-msm/platsmp.c b/arch/arm/mach-msm/platsmp.c
-index f10a1f5..3721b31 100644
 --- a/arch/arm/mach-msm/platsmp.c
 +++ b/arch/arm/mach-msm/platsmp.c
 @@ -12,13 +12,10 @@
@@ -160,7 +151,7 @@ index f10a1f5..3721b31 100644
         * Synchronise with the boot thread.
         */
        spin_lock(&boot_lock);
-@@ -57,7 +47,7 @@ static void msm_secondary_init(unsigned int cpu)
+@@ -57,7 +47,7 @@ static void msm_secondary_init(unsigned
  static void prepare_cold_cpu(unsigned int cpu)
  {
        int ret;
@@ -169,7 +160,7 @@ index f10a1f5..3721b31 100644
                                SCM_FLAG_COLDBOOT_CPU1);
        if (ret == 0) {
                void __iomem *sc1_base_ptr;
-@@ -75,7 +65,6 @@ static void prepare_cold_cpu(unsigned int cpu)
+@@ -75,7 +65,6 @@ static void prepare_cold_cpu(unsigned in
  
  static int msm_boot_secondary(unsigned int cpu, struct task_struct *idle)
  {
@@ -177,7 +168,7 @@ index f10a1f5..3721b31 100644
        static int cold_boot_done;
  
        /* Only need to bring cpu out of reset this way once */
-@@ -91,39 +80,19 @@ static int msm_boot_secondary(unsigned int cpu, struct task_struct *idle)
+@@ -91,39 +80,19 @@ static int msm_boot_secondary(unsigned i
        spin_lock(&boot_lock);
  
        /*
@@ -218,6 +209,3 @@ index f10a1f5..3721b31 100644
  }
  
  /*
--- 
-1.7.10.4
-