use immediate set in target Makefiles
[openwrt/openwrt.git] / target / linux / ixp4xx / Makefile
index 25b60a47b720fe3c96c4b7be6d6802b9d885ea27..a185ce8df59ca5d6a0795519f1066bde65c1e049 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2011 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,17 +8,16 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=armeb
 BOARD:=ixp4xx
-BOARDNAME:=Intel XScale IXP4xx
+BOARDNAME:=Intel IXP4xx
 FEATURES:=squashfs
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS:=generic harddisk
 
-LINUX_VERSION:=2.6.21.6
-
-define Target/Description
-endef
+KERNEL_PATCHVER:=4.4
 
-include $(INCLUDE_DIR)/kernel-build.mk
+include $(INCLUDE_DIR)/target.mk
 
-# include the profiles
--include profiles/*.mk
+DEFAULT_PACKAGES += ixp4xx-microcode fconfig
+KERNELNAME:=zImage
 
-$(eval $(call BuildKernel))
+$(eval $(call BuildTarget))