nuke most of the old ixp4xx patchsets
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / patches-2.6.24 / 032-subsume_power_files.patch
diff --git a/target/linux/ixp4xx/patches-2.6.24/032-subsume_power_files.patch b/target/linux/ixp4xx/patches-2.6.24/032-subsume_power_files.patch
deleted file mode 100644 (file)
index b32d055..0000000
+++ /dev/null
@@ -1,819 +0,0 @@
-From: Rod Whitby <rod@whitby.id.au>
-Subject: ixp4xx: Merge nslu2-power.c into nslu2-setup.c (Patch #4807)
-
-There is no reason to have power control in a separate file from the
-board setup code.  Merge it back into the board setup file, removing
-superfluous header includes and removing superfluous constants from
-the machine header file.
-
-Signed-off-by: Rod Whitby <rod@whitby.id.au>
---
-PATCH FOLLOWS
-KernelVersion: v2.6.24-1917-gaf66bd3
-
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/Makefile
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/Makefile
-+++ linux-2.6.24.7/arch/arm/mach-ixp4xx/Makefile
-@@ -24,9 +24,9 @@ obj-$(CONFIG_MACH_AVILA)     += avila-setup.
- obj-$(CONFIG_MACH_IXDPG425)   += coyote-setup.o
- obj-$(CONFIG_ARCH_ADI_COYOTE) += coyote-setup.o
- obj-$(CONFIG_MACH_GTWX5715)   += gtwx5715-setup.o
--obj-$(CONFIG_MACH_NSLU2)      += nslu2-setup.o nslu2-power.o
--obj-$(CONFIG_MACH_NAS100D)    += nas100d-setup.o nas100d-power.o
--obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o dsmg600-power.o
-+obj-$(CONFIG_MACH_NSLU2)      += nslu2-setup.o
-+obj-$(CONFIG_MACH_NAS100D)    += nas100d-setup.o
-+obj-$(CONFIG_MACH_DSMG600)      += dsmg600-setup.o
- obj-$(CONFIG_MACH_GATEWAY7001)        += gateway7001-setup.o
- obj-$(CONFIG_MACH_WG302V2)    += wg302v2-setup.o
- obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/nslu2-power.c
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/nslu2-power.c
-+++ /dev/null
-@@ -1,92 +0,0 @@
--/*
-- * arch/arm/mach-ixp4xx/nslu2-power.c
-- *
-- * NSLU2 Power/Reset driver
-- *
-- * Copyright (C) 2005 Tower Technologies
-- *
-- * based on nslu2-io.c
-- *  Copyright (C) 2004 Karen Spearel
-- *
-- * Author: Alessandro Zummo <a.zummo@towertech.it>
-- * Maintainers: http://www.nslu2-linux.org/
-- *
-- * This program is free software; you can redistribute it and/or modify
-- * it under the terms of the GNU General Public License version 2 as
-- * published by the Free Software Foundation.
-- *
-- */
--
--#include <linux/module.h>
--#include <linux/reboot.h>
--#include <linux/irq.h>
--#include <linux/interrupt.h>
--#include <linux/reboot.h>
--
--#include <asm/mach-types.h>
--
--static irqreturn_t nslu2_power_handler(int irq, void *dev_id)
--{
--      /* Signal init to do the ctrlaltdel action, this will bypass init if
--       * it hasn't started and do a kernel_restart.
--       */
--      ctrl_alt_del();
--
--      return IRQ_HANDLED;
--}
--
--static irqreturn_t nslu2_reset_handler(int irq, void *dev_id)
--{
--      /* This is the paper-clip reset, it shuts the machine down directly.
--       */
--      machine_power_off();
--
--      return IRQ_HANDLED;
--}
--
--static int __init nslu2_power_init(void)
--{
--      if (!(machine_is_nslu2()))
--              return 0;
--
--      *IXP4XX_GPIO_GPISR = 0x20400000;        /* read the 2 irqs to clr */
--
--      set_irq_type(NSLU2_RB_IRQ, IRQT_LOW);
--      set_irq_type(NSLU2_PB_IRQ, IRQT_HIGH);
--
--      if (request_irq(NSLU2_RB_IRQ, &nslu2_reset_handler,
--              IRQF_DISABLED, "NSLU2 reset button", NULL) < 0) {
--
--              printk(KERN_DEBUG "Reset Button IRQ %d not available\n",
--                      NSLU2_RB_IRQ);
--
--              return -EIO;
--      }
--
--      if (request_irq(NSLU2_PB_IRQ, &nslu2_power_handler,
--              IRQF_DISABLED, "NSLU2 power button", NULL) < 0) {
--
--              printk(KERN_DEBUG "Power Button IRQ %d not available\n",
--                      NSLU2_PB_IRQ);
--
--              return -EIO;
--      }
--
--      return 0;
--}
--
--static void __exit nslu2_power_exit(void)
--{
--      if (!(machine_is_nslu2()))
--              return;
--
--      free_irq(NSLU2_RB_IRQ, NULL);
--      free_irq(NSLU2_PB_IRQ, NULL);
--}
--
--module_init(nslu2_power_init);
--module_exit(nslu2_power_exit);
--
--MODULE_AUTHOR("Alessandro Zummo <a.zummo@towertech.it>");
--MODULE_DESCRIPTION("NSLU2 Power/Reset driver");
--MODULE_LICENSE("GPL");
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/nslu2-setup.c
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/nslu2-setup.c
-+++ linux-2.6.24.7/arch/arm/mach-ixp4xx/nslu2-setup.c
-@@ -3,22 +3,26 @@
-  *
-  * NSLU2 board-setup
-  *
-- * based ixdp425-setup.c:
-+ * Copyright (C) 2008 Rod Whitby <rod@whitby.id.au>
-+ *
-+ * based on ixdp425-setup.c:
-  *      Copyright (C) 2003-2004 MontaVista Software, Inc.
-+ * based on nslu2-power.c:
-+ *    Copyright (C) 2005 Tower Technologies
-  *
-  * Author: Mark Rakes <mrakes at mac.com>
-  * Author: Rod Whitby <rod@whitby.id.au>
-+ * Author: Alessandro Zummo <a.zummo@towertech.it>
-  * Maintainers: http://www.nslu2-linux.org/
-  *
-- * Fixed missing init_time in MACHINE_START kas11 10/22/04
-- * Changed to conform to new style __init ixdp425 kas11 10/22/04
-  */
- #include <linux/if_ether.h>
--#include <linux/kernel.h>
-+#include <linux/irq.h>
- #include <linux/serial.h>
- #include <linux/serial_8250.h>
- #include <linux/leds.h>
-+#include <linux/reboot.h>
- #include <linux/i2c.h>
- #include <linux/i2c-gpio.h>
-@@ -27,6 +31,7 @@
- #include <asm/mach/flash.h>
- #include <asm/mach/time.h>
- #include <asm/io.h>
-+#include <asm/gpio.h>
- static struct flash_platform_data nslu2_flash_data = {
-       .map_name               = "cfi_probe",
-@@ -181,6 +186,25 @@ static void nslu2_power_off(void)
-       gpio_line_set(NSLU2_PO_GPIO, IXP4XX_GPIO_HIGH);
- }
-+static irqreturn_t nslu2_power_handler(int irq, void *dev_id)
-+{
-+      /* Signal init to do the ctrlaltdel action, this will bypass init if
-+       * it hasn't started and do a kernel_restart.
-+       */
-+      ctrl_alt_del();
-+
-+      return IRQ_HANDLED;
-+}
-+
-+static irqreturn_t nslu2_reset_handler(int irq, void *dev_id)
-+{
-+      /* This is the paper-clip reset, it shuts the machine down directly.
-+       */
-+      machine_power_off();
-+
-+      return IRQ_HANDLED;
-+}
-+
- static void __init nslu2_timer_init(void)
- {
-     /* The xtal on this machine is non-standard. */
-@@ -206,8 +230,6 @@ static void __init nslu2_init(void)
-       nslu2_flash_resource.end =
-               IXP4XX_EXP_BUS_BASE(0) + ixp4xx_exp_bus_size - 1;
--      pm_power_off = nslu2_power_off;
--
-       i2c_register_board_info(0, nslu2_i2c_board_info,
-                               ARRAY_SIZE(nslu2_i2c_board_info));
-@@ -220,6 +242,23 @@ static void __init nslu2_init(void)
-       platform_add_devices(nslu2_devices, ARRAY_SIZE(nslu2_devices));
-+      pm_power_off = nslu2_power_off;
-+
-+      if (request_irq(gpio_to_irq(NSLU2_RB_GPIO), &nslu2_reset_handler,
-+              IRQF_DISABLED | IRQF_TRIGGER_LOW,
-+              "NSLU2 reset button", NULL) < 0) {
-+
-+              printk(KERN_DEBUG "Reset Button IRQ %d not available\n",
-+                      gpio_to_irq(NSLU2_RB_GPIO));
-+      }
-+
-+      if (request_irq(gpio_to_irq(NSLU2_PB_GPIO), &nslu2_power_handler,
-+              IRQF_DISABLED | IRQF_TRIGGER_HIGH,
-+              "NSLU2 power button", NULL) < 0) {
-+
-+              printk(KERN_DEBUG "Power Button IRQ %d not available\n",
-+                      gpio_to_irq(NSLU2_PB_GPIO));
-+      }
-       /*
-        * Map in a portion of the flash and read the MAC address.
-Index: linux-2.6.24.7/include/asm-arm/arch-ixp4xx/nslu2.h
-===================================================================
---- linux-2.6.24.7.orig/include/asm-arm/arch-ixp4xx/nslu2.h
-+++ linux-2.6.24.7/include/asm-arm/arch-ixp4xx/nslu2.h
-@@ -39,34 +39,17 @@
- /* Buttons */
--#define NSLU2_PB_GPIO         5
-+#define NSLU2_PB_GPIO         5       /* power button */
- #define NSLU2_PO_GPIO         8       /* power off */
--#define NSLU2_RB_GPIO         12
--
--#define NSLU2_PB_IRQ          IRQ_IXP4XX_GPIO5
--#define NSLU2_RB_IRQ          IRQ_IXP4XX_GPIO12
--
--#define NSLU2_PB_BM           (1L << NSLU2_PB_GPIO)
--#define NSLU2_PO_BM           (1L << NSLU2_PO_GPIO)
--#define NSLU2_RB_BM           (1L << NSLU2_RB_GPIO)
-+#define NSLU2_RB_GPIO         12      /* reset button */
- /* Buzzer */
- #define NSLU2_GPIO_BUZZ               4
--#define NSLU2_BZ_BM           (1L << NSLU2_GPIO_BUZZ)
- /* LEDs */
- #define NSLU2_LED_RED_GPIO    0
- #define NSLU2_LED_GRN_GPIO    1
--
--#define NSLU2_LED_RED_BM      (1L << NSLU2_LED_RED_GPIO)
--#define NSLU2_LED_GRN_BM      (1L << NSLU2_LED_GRN_GPIO)
--
- #define NSLU2_LED_DISK1_GPIO  3
- #define NSLU2_LED_DISK2_GPIO  2
--
--#define NSLU2_LED_DISK1_BM    (1L << NSLU2_LED_DISK1_GPIO)
--#define NSLU2_LED_DISK2_BM    (1L << NSLU2_LED_DISK2_GPIO)
--
--
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/nas100d-power.c
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/nas100d-power.c
-+++ /dev/null
-@@ -1,128 +0,0 @@
--/*
-- * arch/arm/mach-ixp4xx/nas100d-power.c
-- *
-- * NAS 100d Power/Reset driver
-- *
-- * Copyright (C) 2005 Tower Technologies
-- *
-- * based on nas100d-io.c
-- *  Copyright (C) 2004 Karen Spearel
-- *
-- * Author: Alessandro Zummo <a.zummo@towertech.it>
-- * Maintainers: http://www.nslu2-linux.org/
-- *
-- * This program is free software; you can redistribute it and/or modify
-- * it under the terms of the GNU General Public License version 2 as
-- * published by the Free Software Foundation.
-- *
-- */
--
--#include <linux/interrupt.h>
--#include <linux/irq.h>
--#include <linux/module.h>
--#include <linux/reboot.h>
--#include <linux/jiffies.h>
--#include <linux/timer.h>
--
--#include <asm/gpio.h>
--#include <asm/mach-types.h>
--
--/* This is used to make sure the power-button pusher is serious.  The button
-- * must be held until the value of this counter reaches zero.
-- */
--static int power_button_countdown;
--
--/* Must hold the button down for at least this many counts to be processed */
--#define PBUTTON_HOLDDOWN_COUNT 4 /* 2 secs */
--
--static void nas100d_power_handler(unsigned long data);
--static DEFINE_TIMER(nas100d_power_timer, nas100d_power_handler, 0, 0);
--
--static void nas100d_power_handler(unsigned long data)
--{
--      /* This routine is called twice per second to check the
--       * state of the power button.
--       */
--
--      if (gpio_get_value(NAS100D_PB_GPIO)) {
--
--              /* IO Pin is 1 (button pushed) */
--              if (power_button_countdown > 0)
--                      power_button_countdown--;
--
--      } else {
--
--              /* Done on button release, to allow for auto-power-on mods. */
--              if (power_button_countdown == 0) {
--                      /* Signal init to do the ctrlaltdel action,
--                       * this will bypass init if it hasn't started
--                       * and do a kernel_restart.
--                       */
--                      ctrl_alt_del();
--
--                      /* Change the state of the power LED to "blink" */
--                      gpio_line_set(NAS100D_LED_PWR_GPIO, IXP4XX_GPIO_LOW);
--              } else {
--                      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
--              }
--      }
--
--      mod_timer(&nas100d_power_timer, jiffies + msecs_to_jiffies(500));
--}
--
--static irqreturn_t nas100d_reset_handler(int irq, void *dev_id)
--{
--      /* This is the paper-clip reset, it shuts the machine down directly. */
--      machine_power_off();
--
--      return IRQ_HANDLED;
--}
--
--static int __init nas100d_power_init(void)
--{
--      if (!(machine_is_nas100d()))
--              return 0;
--
--      set_irq_type(gpio_to_irq(NAS100D_RB_GPIO), IRQT_LOW);
--
--      if (request_irq(gpio_to_irq(NAS100D_RB_GPIO), &nas100d_reset_handler,
--              IRQF_DISABLED, "NAS100D reset button", NULL) < 0) {
--
--              printk(KERN_DEBUG "Reset Button IRQ %d not available\n",
--                      gpio_to_irq(NAS100D_RB_GPIO));
--
--              return -EIO;
--      }
--
--      /* The power button on the Iomega NAS100d is on GPIO 14, but
--       * it cannot handle interrupts on that GPIO line.  So we'll
--       * have to poll it with a kernel timer.
--       */
--
--      /* Make sure that the power button GPIO is set up as an input */
--      gpio_line_config(NAS100D_PB_GPIO, IXP4XX_GPIO_IN);
--
--      /* Set the initial value for the power button IRQ handler */
--      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
--
--      mod_timer(&nas100d_power_timer, jiffies + msecs_to_jiffies(500));
--
--      return 0;
--}
--
--static void __exit nas100d_power_exit(void)
--{
--      if (!(machine_is_nas100d()))
--              return;
--
--      del_timer_sync(&nas100d_power_timer);
--
--      free_irq(gpio_to_irq(NAS100D_RB_GPIO), NULL);
--}
--
--module_init(nas100d_power_init);
--module_exit(nas100d_power_exit);
--
--MODULE_AUTHOR("Alessandro Zummo <a.zummo@towertech.it>");
--MODULE_DESCRIPTION("NAS100D Power/Reset driver");
--MODULE_LICENSE("GPL");
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/nas100d-setup.c
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/nas100d-setup.c
-+++ linux-2.6.24.7/arch/arm/mach-ixp4xx/nas100d-setup.c
-@@ -3,8 +3,14 @@
-  *
-  * NAS 100d board-setup
-  *
-- * based ixdp425-setup.c:
-+ * Copyright (C) 2008 Rod Whitby <rod@whitby.id.au>
-+ *
-+ * based on ixdp425-setup.c:
-  *      Copyright (C) 2003-2004 MontaVista Software, Inc.
-+ * based on nas100d-power.c:
-+ *    Copyright (C) 2005 Tower Technologies
-+ * based on nas100d-io.c
-+ *    Copyright (C) 2004 Karen Spearel
-  *
-  * Author: Alessandro Zummo <a.zummo@towertech.it>
-  * Author: Rod Whitby <rod@whitby.id.au>
-@@ -13,10 +19,13 @@
-  */
- #include <linux/if_ether.h>
--#include <linux/kernel.h>
-+#include <linux/irq.h>
-+#include <linux/jiffies.h>
-+#include <linux/timer.h>
- #include <linux/serial.h>
- #include <linux/serial_8250.h>
- #include <linux/leds.h>
-+#include <linux/reboot.h>
- #include <linux/i2c.h>
- #include <linux/i2c-gpio.h>
-@@ -24,6 +33,7 @@
- #include <asm/mach/arch.h>
- #include <asm/mach/flash.h>
- #include <asm/io.h>
-+#include <asm/gpio.h>
- static struct flash_platform_data nas100d_flash_data = {
-       .map_name               = "cfi_probe",
-@@ -168,6 +178,57 @@ static void nas100d_power_off(void)
-       gpio_line_set(NAS100D_PO_GPIO, IXP4XX_GPIO_HIGH);
- }
-+/* This is used to make sure the power-button pusher is serious.  The button
-+ * must be held until the value of this counter reaches zero.
-+ */
-+static int power_button_countdown;
-+
-+/* Must hold the button down for at least this many counts to be processed */
-+#define PBUTTON_HOLDDOWN_COUNT 4 /* 2 secs */
-+
-+static void nas100d_power_handler(unsigned long data);
-+static DEFINE_TIMER(nas100d_power_timer, nas100d_power_handler, 0, 0);
-+
-+static void nas100d_power_handler(unsigned long data)
-+{
-+      /* This routine is called twice per second to check the
-+       * state of the power button.
-+       */
-+
-+      if (gpio_get_value(NAS100D_PB_GPIO)) {
-+
-+              /* IO Pin is 1 (button pushed) */
-+              if (power_button_countdown > 0)
-+                      power_button_countdown--;
-+
-+      } else {
-+
-+              /* Done on button release, to allow for auto-power-on mods. */
-+              if (power_button_countdown == 0) {
-+                      /* Signal init to do the ctrlaltdel action,
-+                       * this will bypass init if it hasn't started
-+                       * and do a kernel_restart.
-+                       */
-+                      ctrl_alt_del();
-+
-+                      /* Change the state of the power LED to "blink" */
-+                      gpio_line_set(NAS100D_LED_PWR_GPIO, IXP4XX_GPIO_LOW);
-+              } else {
-+                      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
-+              }
-+      }
-+
-+      mod_timer(&nas100d_power_timer, jiffies + msecs_to_jiffies(500));
-+}
-+
-+static irqreturn_t nas100d_reset_handler(int irq, void *dev_id)
-+{
-+      /* This is the paper-clip reset, it shuts the machine down directly. */
-+      machine_power_off();
-+
-+      return IRQ_HANDLED;
-+}
-+
- static void __init nas100d_init(void)
- {
-       DECLARE_MAC_BUF(mac_buf);
-@@ -183,8 +244,6 @@ static void __init nas100d_init(void)
-       nas100d_flash_resource.end =
-               IXP4XX_EXP_BUS_BASE(0) + ixp4xx_exp_bus_size - 1;
--      pm_power_off = nas100d_power_off;
--
-       i2c_register_board_info(0, nas100d_i2c_board_info,
-                               ARRAY_SIZE(nas100d_i2c_board_info));
-@@ -197,6 +256,29 @@ static void __init nas100d_init(void)
-       platform_add_devices(nas100d_devices, ARRAY_SIZE(nas100d_devices));
-+      pm_power_off = nas100d_power_off;
-+
-+      if (request_irq(gpio_to_irq(NAS100D_RB_GPIO), &nas100d_reset_handler,
-+              IRQF_DISABLED | IRQF_TRIGGER_LOW,
-+              "NAS100D reset button", NULL) < 0) {
-+
-+              printk(KERN_DEBUG "Reset Button IRQ %d not available\n",
-+                      gpio_to_irq(NAS100D_RB_GPIO));
-+      }
-+
-+      /* The power button on the Iomega NAS100d is on GPIO 14, but
-+       * it cannot handle interrupts on that GPIO line.  So we'll
-+       * have to poll it with a kernel timer.
-+       */
-+
-+      /* Make sure that the power button GPIO is set up as an input */
-+      gpio_line_config(NAS100D_PB_GPIO, IXP4XX_GPIO_IN);
-+
-+      /* Set the initial value for the power button IRQ handler */
-+      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
-+
-+      mod_timer(&nas100d_power_timer, jiffies + msecs_to_jiffies(500));
-+
-       /*
-        * Map in a portion of the flash and read the MAC address.
-        * Since it is stored in BE in the flash itself, we need to
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/dsmg600-power.c
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/dsmg600-power.c
-+++ /dev/null
-@@ -1,129 +0,0 @@
--/*
-- * arch/arm/mach-ixp4xx/dsmg600-power.c
-- *
-- * DSM-G600 Power/Reset driver
-- * Author: Michael Westerhof <mwester@dls.net>
-- *
-- * Based on nslu2-power.c
-- *  Copyright (C) 2005 Tower Technologies
-- *  Author: Alessandro Zummo <a.zummo@towertech.it>
-- *
-- * which was based on nslu2-io.c
-- *  Copyright (C) 2004 Karen Spearel
-- *
-- * Maintainers: http://www.nslu2-linux.org/
-- *
-- * This program is free software; you can redistribute it and/or modify
-- * it under the terms of the GNU General Public License version 2 as
-- * published by the Free Software Foundation.
-- *
-- */
--
--#include <linux/module.h>
--#include <linux/reboot.h>
--#include <linux/interrupt.h>
--#include <linux/irq.h>
--#include <linux/jiffies.h>
--#include <linux/timer.h>
--
--#include <asm/gpio.h>
--#include <asm/mach-types.h>
--
--/* This is used to make sure the power-button pusher is serious.  The button
-- * must be held until the value of this counter reaches zero.
-- */
--static int power_button_countdown;
--
--/* Must hold the button down for at least this many counts to be processed */
--#define PBUTTON_HOLDDOWN_COUNT 4 /* 2 secs */
--
--static void dsmg600_power_handler(unsigned long data);
--static DEFINE_TIMER(dsmg600_power_timer, dsmg600_power_handler, 0, 0);
--
--static void dsmg600_power_handler(unsigned long data)
--{
--      /* This routine is called twice per second to check the
--       * state of the power button.
--       */
--
--      if (gpio_get_value(DSMG600_PB_GPIO)) {
--
--              /* IO Pin is 1 (button pushed) */
--              if (power_button_countdown > 0)
--                      power_button_countdown--;
--
--      } else {
--
--              /* Done on button release, to allow for auto-power-on mods. */
--              if (power_button_countdown == 0) {
--                      /* Signal init to do the ctrlaltdel action,
--                       * this will bypass init if it hasn't started
--                       * and do a kernel_restart.
--                       */
--                      ctrl_alt_del();
--
--                      /* Change the state of the power LED to "blink" */
--                      gpio_line_set(DSMG600_LED_PWR_GPIO, IXP4XX_GPIO_LOW);
--              } else {
--                      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
--              }
--      }
--
--      mod_timer(&dsmg600_power_timer, jiffies + msecs_to_jiffies(500));
--}
--
--static irqreturn_t dsmg600_reset_handler(int irq, void *dev_id)
--{
--      /* This is the paper-clip reset, it shuts the machine down directly. */
--      machine_power_off();
--
--      return IRQ_HANDLED;
--}
--
--static int __init dsmg600_power_init(void)
--{
--      if (!(machine_is_dsmg600()))
--              return 0;
--
--      if (request_irq(gpio_to_irq(DSMG600_RB_GPIO), &dsmg600_reset_handler,
--              IRQF_DISABLED | IRQF_TRIGGER_LOW, "DSM-G600 reset button",
--              NULL) < 0) {
--
--              printk(KERN_DEBUG "Reset Button IRQ %d not available\n",
--                      gpio_to_irq(DSMG600_RB_GPIO));
--
--              return -EIO;
--      }
--
--      /* The power button on the D-Link DSM-G600 is on GPIO 15, but
--       * it cannot handle interrupts on that GPIO line.  So we'll
--       * have to poll it with a kernel timer.
--       */
--
--      /* Make sure that the power button GPIO is set up as an input */
--      gpio_line_config(DSMG600_PB_GPIO, IXP4XX_GPIO_IN);
--
--      /* Set the initial value for the power button IRQ handler */
--      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
--
--      mod_timer(&dsmg600_power_timer, jiffies + msecs_to_jiffies(500));
--
--      return 0;
--}
--
--static void __exit dsmg600_power_exit(void)
--{
--      if (!(machine_is_dsmg600()))
--              return;
--
--      del_timer_sync(&dsmg600_power_timer);
--
--      free_irq(gpio_to_irq(DSMG600_RB_GPIO), NULL);
--}
--
--module_init(dsmg600_power_init);
--module_exit(dsmg600_power_exit);
--
--MODULE_AUTHOR("Michael Westerhof <mwester@dls.net>");
--MODULE_DESCRIPTION("DSM-G600 Power/Reset driver");
--MODULE_LICENSE("GPL");
-Index: linux-2.6.24.7/arch/arm/mach-ixp4xx/dsmg600-setup.c
-===================================================================
---- linux-2.6.24.7.orig/arch/arm/mach-ixp4xx/dsmg600-setup.c
-+++ linux-2.6.24.7/arch/arm/mach-ixp4xx/dsmg600-setup.c
-@@ -1,20 +1,29 @@
- /*
-  * DSM-G600 board-setup
-  *
-+ * Copyright (C) 2008 Rod Whitby <rod@whitby.id.au>
-  * Copyright (C) 2006 Tower Technologies
-- * Author: Alessandro Zummo <a.zummo@towertech.it>
-  *
-- * based ixdp425-setup.c:
-+ * based on ixdp425-setup.c:
-  *      Copyright (C) 2003-2004 MontaVista Software, Inc.
-+ * based on nslu2-power.c:
-+ *    Copyright (C) 2005 Tower Technologies
-+ * based on nslu2-io.c:
-+ *    Copyright (C) 2004 Karen Spearel
-  *
-  * Author: Alessandro Zummo <a.zummo@towertech.it>
-+ * Author: Michael Westerhof <mwester@dls.net>
-+ * Author: Rod Whitby <rod@whitby.id.au>
-  * Maintainers: http://www.nslu2-linux.org/
-  */
--#include <linux/kernel.h>
-+#include <linux/irq.h>
-+#include <linux/jiffies.h>
-+#include <linux/timer.h>
- #include <linux/serial.h>
- #include <linux/serial_8250.h>
- #include <linux/leds.h>
-+#include <linux/reboot.h>
- #include <linux/i2c.h>
- #include <linux/i2c-gpio.h>
-@@ -22,6 +31,7 @@
- #include <asm/mach/arch.h>
- #include <asm/mach/flash.h>
- #include <asm/mach/time.h>
-+#include <asm/gpio.h>
- static struct flash_platform_data dsmg600_flash_data = {
-       .map_name               = "cfi_probe",
-@@ -140,6 +150,57 @@ static void dsmg600_power_off(void)
-       gpio_line_set(DSMG600_PO_GPIO, IXP4XX_GPIO_HIGH);
- }
-+/* This is used to make sure the power-button pusher is serious.  The button
-+ * must be held until the value of this counter reaches zero.
-+ */
-+static int power_button_countdown;
-+
-+/* Must hold the button down for at least this many counts to be processed */
-+#define PBUTTON_HOLDDOWN_COUNT 4 /* 2 secs */
-+
-+static void dsmg600_power_handler(unsigned long data);
-+static DEFINE_TIMER(dsmg600_power_timer, dsmg600_power_handler, 0, 0);
-+
-+static void dsmg600_power_handler(unsigned long data)
-+{
-+      /* This routine is called twice per second to check the
-+       * state of the power button.
-+       */
-+
-+      if (gpio_get_value(DSMG600_PB_GPIO)) {
-+
-+              /* IO Pin is 1 (button pushed) */
-+              if (power_button_countdown > 0)
-+                      power_button_countdown--;
-+
-+      } else {
-+
-+              /* Done on button release, to allow for auto-power-on mods. */
-+              if (power_button_countdown == 0) {
-+                      /* Signal init to do the ctrlaltdel action,
-+                       * this will bypass init if it hasn't started
-+                       * and do a kernel_restart.
-+                       */
-+                      ctrl_alt_del();
-+
-+                      /* Change the state of the power LED to "blink" */
-+                      gpio_line_set(DSMG600_LED_PWR_GPIO, IXP4XX_GPIO_LOW);
-+              } else {
-+                      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
-+              }
-+      }
-+
-+      mod_timer(&dsmg600_power_timer, jiffies + msecs_to_jiffies(500));
-+}
-+
-+static irqreturn_t dsmg600_reset_handler(int irq, void *dev_id)
-+{
-+      /* This is the paper-clip reset, it shuts the machine down directly. */
-+      machine_power_off();
-+
-+      return IRQ_HANDLED;
-+}
-+
- static void __init dsmg600_timer_init(void)
- {
-     /* The xtal on this machine is non-standard. */
-@@ -164,8 +225,6 @@ static void __init dsmg600_init(void)
-       dsmg600_flash_resource.end =
-               IXP4XX_EXP_BUS_BASE(0) + ixp4xx_exp_bus_size - 1;
--      pm_power_off = dsmg600_power_off;
--
-       i2c_register_board_info(0, dsmg600_i2c_board_info,
-                               ARRAY_SIZE(dsmg600_i2c_board_info));
-@@ -176,6 +235,29 @@ static void __init dsmg600_init(void)
-         (void)platform_device_register(&dsmg600_uart);
-       platform_add_devices(dsmg600_devices, ARRAY_SIZE(dsmg600_devices));
-+
-+      pm_power_off = dsmg600_power_off;
-+
-+      if (request_irq(gpio_to_irq(DSMG600_RB_GPIO), &dsmg600_reset_handler,
-+              IRQF_DISABLED | IRQF_TRIGGER_LOW,
-+              "DSM-G600 reset button", NULL) < 0) {
-+
-+              printk(KERN_DEBUG "Reset Button IRQ %d not available\n",
-+                      gpio_to_irq(DSMG600_RB_GPIO));
-+      }
-+
-+      /* The power button on the D-Link DSM-G600 is on GPIO 15, but
-+       * it cannot handle interrupts on that GPIO line.  So we'll
-+       * have to poll it with a kernel timer.
-+       */
-+
-+      /* Make sure that the power button GPIO is set up as an input */
-+      gpio_line_config(DSMG600_PB_GPIO, IXP4XX_GPIO_IN);
-+
-+      /* Set the initial value for the power button IRQ handler */
-+      power_button_countdown = PBUTTON_HOLDDOWN_COUNT;
-+
-+      mod_timer(&dsmg600_power_timer, jiffies + msecs_to_jiffies(500));
- }
- MACHINE_START(DSMG600, "D-Link DSM-G600 RevA")