[ixp4xx]: support only 2.6.32 and 2.6.36
[openwrt/svn-archive/archive.git] / target / linux / ixp4xx / patches-2.6.35 / 115-sidewinder_support.patch
diff --git a/target/linux/ixp4xx/patches-2.6.35/115-sidewinder_support.patch b/target/linux/ixp4xx/patches-2.6.35/115-sidewinder_support.patch
deleted file mode 100644 (file)
index bad0826..0000000
+++ /dev/null
@@ -1,282 +0,0 @@
-From 60bdaaaf3446b4237566c6e04855186fc7bd766b Mon Sep 17 00:00:00 2001
-From: Imre Kaloz <kaloz@openwrt.org>
-Date: Sun, 13 Jul 2008 22:46:45 +0200
-Subject: [PATCH] Add support for the ADI Sidewinder
-
-Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
----
- arch/arm/mach-ixp4xx/Kconfig            |   10 ++-
- arch/arm/mach-ixp4xx/Makefile           |    2 +
- arch/arm/mach-ixp4xx/sidewinder-pci.c   |   68 ++++++++++++++
- arch/arm/mach-ixp4xx/sidewinder-setup.c |  151 +++++++++++++++++++++++++++++++
- 4 files changed, 230 insertions(+), 1 deletions(-)
- create mode 100644 arch/arm/mach-ixp4xx/sidewinder-pci.c
- create mode 100644 arch/arm/mach-ixp4xx/sidewinder-setup.c
-
---- a/arch/arm/mach-ixp4xx/Kconfig
-+++ b/arch/arm/mach-ixp4xx/Kconfig
-@@ -81,6 +81,14 @@ config MACH_PRONGHORN
- config MACH_PRONGHORNMETRO
-       def_bool MACH_PRONGHORN
-+config MACH_SIDEWINDER
-+      bool "ADI Sidewinder"
-+      select PCI
-+      help
-+        Say 'Y' here if you want your kernel to support the ADI 
-+        Engineering Sidewinder board. For more information on this
-+        platform, see http://www.adiengineering.com
-+
- config ARCH_IXDP425
-       bool "IXDP425"
-       help
-@@ -169,7 +177,7 @@ config MACH_FSG
- #
- config CPU_IXP46X
-       bool
--      depends on MACH_IXDP465
-+      depends on MACH_IXDP465 || MACH_SIDEWINDER
-       default y
- config CPU_IXP43X
---- a/arch/arm/mach-ixp4xx/Makefile
-+++ b/arch/arm/mach-ixp4xx/Makefile
-@@ -18,6 +18,7 @@ obj-pci-$(CONFIG_MACH_WG302V1)               += wg302
- obj-pci-$(CONFIG_MACH_WG302V2)                += wg302v2-pci.o
- obj-pci-$(CONFIG_MACH_FSG)            += fsg-pci.o
- obj-pci-$(CONFIG_MACH_PRONGHORN)      += pronghorn-pci.o
-+obj-pci-$(CONFIG_MACH_SIDEWINDER)     += sidewinder-pci.o
- obj-y += common.o
-@@ -35,6 +36,7 @@ obj-$(CONFIG_MACH_WG302V2)   += wg302v2-se
- obj-$(CONFIG_MACH_FSG)                += fsg-setup.o
- obj-$(CONFIG_MACH_GORAMO_MLR) += goramo_mlr.o
- obj-$(CONFIG_MACH_PRONGHORN)  += pronghorn-setup.o
-+obj-$(CONFIG_MACH_SIDEWINDER) += sidewinder-setup.o
- obj-$(CONFIG_PCI)             += $(obj-pci-$(CONFIG_PCI)) common-pci.o
- obj-$(CONFIG_IXP4XX_QMGR)     += ixp4xx_qmgr.o
---- /dev/null
-+++ b/arch/arm/mach-ixp4xx/sidewinder-pci.c
-@@ -0,0 +1,68 @@
-+/*
-+ * arch/arch/mach-ixp4xx/pronghornmetro-pci.c
-+ *
-+ * PCI setup routines for ADI Engineering Sidewinder
-+ *
-+ * Copyright (C) 2008 Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * based on coyote-pci.c:
-+ *    Copyright (C) 2002 Jungo Software Technologies.
-+ *    Copyright (C) 2003 MontaVista Softwrae, Inc.
-+ *
-+ * Maintainer: Imre Kaloz <kaloz@openwrt.org>
-+ *
-+ * This program is free software; you can redistribute it and/or modify
-+ * it under the terms of the GNU General Public License version 2 as
-+ * published by the Free Software Foundation.
-+ *
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/pci.h>
-+#include <linux/init.h>
-+#include <linux/irq.h>
-+
-+#include <asm/mach-types.h>
-+#include <mach/hardware.h>
-+#include <asm/irq.h>
-+
-+#include <asm/mach/pci.h>
-+
-+void __init sidewinder_pci_preinit(void)
-+{
-+      set_irq_type(IRQ_IXP4XX_GPIO11, IRQ_TYPE_LEVEL_LOW);
-+      set_irq_type(IRQ_IXP4XX_GPIO10, IRQ_TYPE_LEVEL_LOW);
-+      set_irq_type(IRQ_IXP4XX_GPIO9, IRQ_TYPE_LEVEL_LOW);
-+
-+      ixp4xx_pci_preinit();
-+}
-+
-+static int __init sidewinder_map_irq(struct pci_dev *dev, u8 slot, u8 pin)
-+{
-+      if (slot == 1)
-+              return IRQ_IXP4XX_GPIO11;
-+      else if (slot == 2)
-+              return IRQ_IXP4XX_GPIO10;
-+      else if (slot == 3)
-+              return IRQ_IXP4XX_GPIO9;
-+      else
-+              return -1;
-+}
-+
-+struct hw_pci sidewinder_pci __initdata = {
-+      .nr_controllers = 1,
-+      .preinit        = sidewinder_pci_preinit,
-+      .swizzle        = pci_std_swizzle,
-+      .setup          = ixp4xx_setup,
-+      .scan           = ixp4xx_scan_bus,
-+      .map_irq        = sidewinder_map_irq,
-+};
-+
-+int __init sidewinder_pci_init(void)
-+{
-+      if (machine_is_sidewinder())
-+              pci_common_init(&sidewinder_pci);
-+      return 0;
-+}
-+
-+subsys_initcall(sidewinder_pci_init);
---- /dev/null
-+++ b/arch/arm/mach-ixp4xx/sidewinder-setup.c
-@@ -0,0 +1,149 @@
-+/*
-+ * arch/arm/mach-ixp4xx/sidewinder-setup.c
-+ *
-+ * Board setup for the ADI Engineering Sidewinder
-+ *
-+ * Copyright (C) 2008 Imre Kaloz <Kaloz@openwrt.org>
-+ *
-+ * based on coyote-setup.c:
-+ *      Copyright (C) 2003-2005 MontaVista Software, Inc.
-+ *
-+ * Author: Imre Kaloz <Kaloz@openwrt.org>
-+ */
-+
-+#include <linux/kernel.h>
-+#include <linux/serial.h>
-+#include <linux/serial_8250.h>
-+
-+#include <asm/mach-types.h>
-+#include <asm/mach/arch.h>
-+#include <asm/mach/flash.h>
-+
-+static struct flash_platform_data sidewinder_flash_data = {
-+      .map_name       = "cfi_probe",
-+      .width          = 2,
-+};
-+
-+static struct resource sidewinder_flash_resource = {
-+      .flags          = IORESOURCE_MEM,
-+};
-+
-+static struct platform_device sidewinder_flash = {
-+      .name           = "IXP4XX-Flash",
-+      .id             = 0,
-+      .dev            = {
-+              .platform_data = &sidewinder_flash_data,
-+      },
-+      .num_resources  = 1,
-+      .resource       = &sidewinder_flash_resource,
-+};
-+
-+static struct resource sidewinder_uart_resources[] = {
-+      {
-+              .start  = IXP4XX_UART1_BASE_PHYS,
-+              .end    = IXP4XX_UART1_BASE_PHYS + 0x0fff,
-+              .flags  = IORESOURCE_MEM,
-+      },
-+      {
-+              .start  = IXP4XX_UART2_BASE_PHYS,
-+              .end    = IXP4XX_UART2_BASE_PHYS + 0x0fff,
-+              .flags  = IORESOURCE_MEM,
-+      }
-+};
-+
-+static struct plat_serial8250_port sidewinder_uart_data[] = {
-+      {
-+              .mapbase        = IXP4XX_UART1_BASE_PHYS,
-+              .membase        = (char *)IXP4XX_UART1_BASE_VIRT + REG_OFFSET,
-+              .irq            = IRQ_IXP4XX_UART1,
-+              .flags          = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
-+              .iotype         = UPIO_MEM,
-+              .regshift       = 2,
-+              .uartclk        = IXP4XX_UART_XTAL,
-+      },
-+      {
-+              .mapbase        = IXP4XX_UART2_BASE_PHYS,
-+              .membase        = (char *)IXP4XX_UART2_BASE_VIRT + REG_OFFSET,
-+              .irq            = IRQ_IXP4XX_UART2,
-+              .flags          = UPF_BOOT_AUTOCONF | UPF_SKIP_TEST,
-+              .iotype         = UPIO_MEM,
-+              .regshift       = 2,
-+              .uartclk        = IXP4XX_UART_XTAL,
-+      },
-+      { },
-+};
-+
-+static struct platform_device sidewinder_uart = {
-+      .name           = "serial8250",
-+      .id             = PLAT8250_DEV_PLATFORM,
-+      .dev            = {
-+              .platform_data  = sidewinder_uart_data,
-+      },
-+      .num_resources  = ARRAY_SIZE(sidewinder_uart_resources),
-+      .resource       = sidewinder_uart_resources,
-+};
-+
-+static struct eth_plat_info sidewinder_plat_eth[] = {
-+      {
-+              .phy            = 5,
-+              .rxq            = 3,
-+              .txreadyq       = 20,
-+      }, {
-+              .phy            = IXP4XX_ETH_PHY_MAX_ADDR,
-+              .phy_mask       = 0x1e,
-+              .rxq            = 4,
-+              .txreadyq       = 21,
-+      }, {
-+              .phy            = 31,
-+              .rxq            = 2,
-+              .txreadyq       = 19,
-+      }
-+};
-+
-+static struct platform_device sidewinder_eth[] = {
-+      {
-+              .name                   = "ixp4xx_eth",
-+              .id                     = IXP4XX_ETH_NPEB,
-+              .dev.platform_data      = sidewinder_plat_eth,
-+      }, {
-+              .name                   = "ixp4xx_eth",
-+              .id                     = IXP4XX_ETH_NPEC,
-+              .dev.platform_data      = sidewinder_plat_eth + 1,
-+      }, {
-+              .name                   = "ixp4xx_eth",
-+              .id                     = IXP4XX_ETH_NPEA,
-+              .dev.platform_data      = sidewinder_plat_eth + 2,
-+      }
-+};
-+
-+static struct platform_device *sidewinder_devices[] __initdata = {
-+      &sidewinder_flash,
-+      &sidewinder_uart,
-+      &sidewinder_eth[0],
-+      &sidewinder_eth[1],
-+      &sidewinder_eth[2],
-+};
-+
-+static void __init sidewinder_init(void)
-+{
-+      ixp4xx_sys_init();
-+
-+      sidewinder_flash_resource.start = IXP4XX_EXP_BUS_BASE(0);
-+      sidewinder_flash_resource.end = IXP4XX_EXP_BUS_BASE(0) + SZ_64M - 1;
-+
-+      *IXP4XX_EXP_CS0 |= IXP4XX_FLASH_WRITABLE;
-+      *IXP4XX_EXP_CS1 = *IXP4XX_EXP_CS0;
-+
-+      platform_add_devices(sidewinder_devices, ARRAY_SIZE(sidewinder_devices));
-+}
-+
-+MACHINE_START(SIDEWINDER, "ADI Engineering Sidewinder")
-+      /* Maintainer: Imre Kaloz <kaloz@openwrt.org> */
-+      .phys_io        = IXP4XX_PERIPHERAL_BASE_PHYS,
-+      .io_pg_offst    = ((IXP4XX_PERIPHERAL_BASE_VIRT) >> 18) & 0xfffc,
-+      .map_io         = ixp4xx_map_io,
-+      .init_irq       = ixp4xx_init_irq,
-+      .timer          = &ixp4xx_timer,
-+      .boot_params    = 0x0100,
-+      .init_machine   = sidewinder_init,
-+MACHINE_END