jh71x0: refresh patches and configs once again
[openwrt/staging/wigyori.git] / target / linux / jh71x0 / modules.mk
diff --git a/target/linux/jh71x0/modules.mk b/target/linux/jh71x0/modules.mk
new file mode 100644 (file)
index 0000000..1aa9328
--- /dev/null
@@ -0,0 +1,13 @@
+define KernelPackage/pcie-starfive
+  TITLE:=JH7110 PCIe controller support
+  DEPENDS:=@TARGET_jh71x0
+  KCONFIG:=CONFIG_PCIE_STARFIVE
+  FILES:=$(LINUX_DIR)/drivers/pci/controller/pcie-starfive.ko
+  AUTOLOAD:=$(call AutoLoad,41,pcie-starfive,1)
+endef
+
+define KernelPackage/pcie-starfive/description
+ PCIe support for JH7110
+endef
+
+$(eval $(call KernelPackage,pcie-starfive))