jh71x0: refresh patches and configs once again
[openwrt/staging/wigyori.git] / target / linux / jh71x0 / patches-6.1 / 0004-clk-starfive-Factor-out-common-JH7100-and-JH7110-cod.patch
index e00e0d21d5eeba37c6bfd27dd3a6c4302dfd85be..91ff1cf8f1ca5403024390dc8a7b87d0fe8db785 100644 (file)
@@ -1,7 +1,7 @@
-From ee86da666ea5f7868334d109effa96ac7b25143c Mon Sep 17 00:00:00 2001
+From 6f14eb919e5b92076e17aec5388655348963eef7 Mon Sep 17 00:00:00 2001
 From: Emil Renner Berthing <kernel@esmil.dk>
 Date: Sat, 1 Apr 2023 19:19:16 +0800
-Subject: [PATCH 004/129] clk: starfive: Factor out common JH7100 and JH7110
+Subject: [PATCH 004/122] clk: starfive: Factor out common JH7100 and JH7110
  code
 
 The clock control registers on the StarFive JH7100 and JH7110 work
@@ -24,7 +24,7 @@ Signed-off-by: Conor Dooley <conor.dooley@microchip.com>
  create mode 100644 drivers/clk/starfive/clk-starfive-jh71x0.c
 
 diff --git a/drivers/clk/starfive/Kconfig b/drivers/clk/starfive/Kconfig
-index ef3517f4a..3ceeb19b5 100644
+index ef3517f4a276..3ceeb19b5eda 100644
 --- a/drivers/clk/starfive/Kconfig
 +++ b/drivers/clk/starfive/Kconfig
 @@ -1,8 +1,12 @@
@@ -49,7 +49,7 @@ index ef3517f4a..3ceeb19b5 100644
        help
          Say Y or M here to support the audio clocks on the StarFive JH7100
 diff --git a/drivers/clk/starfive/Makefile b/drivers/clk/starfive/Makefile
-index 0fa8ecb9e..82edfa9f9 100644
+index 0fa8ecb9ec1c..82edfa9f9cb8 100644
 --- a/drivers/clk/starfive/Makefile
 +++ b/drivers/clk/starfive/Makefile
 @@ -1,4 +1,5 @@
@@ -60,7 +60,7 @@ index 0fa8ecb9e..82edfa9f9 100644
  obj-$(CONFIG_CLK_STARFIVE_JH7100)     += clk-starfive-jh7100.o
  obj-$(CONFIG_CLK_STARFIVE_JH7100_AUDIO)       += clk-starfive-jh7100-audio.o
 diff --git a/drivers/clk/starfive/clk-starfive-jh7100.c b/drivers/clk/starfive/clk-starfive-jh7100.c
-index 691aeebc7..eea52f16a 100644
+index 691aeebc7092..eea52f16af0d 100644
 --- a/drivers/clk/starfive/clk-starfive-jh7100.c
 +++ b/drivers/clk/starfive/clk-starfive-jh7100.c
 @@ -7,15 +7,10 @@
@@ -407,7 +407,7 @@ index 691aeebc7..eea52f16a 100644
  {
        struct jh7100_clk_priv *priv = data;
 diff --git a/drivers/clk/starfive/clk-starfive-jh7100.h b/drivers/clk/starfive/clk-starfive-jh7100.h
-index f116be574..a8ba6e25b 100644
+index f116be5740a5..a8ba6e25b5ce 100644
 --- a/drivers/clk/starfive/clk-starfive-jh7100.h
 +++ b/drivers/clk/starfive/clk-starfive-jh7100.h
 @@ -4,6 +4,8 @@
@@ -421,7 +421,7 @@ index f116be574..a8ba6e25b 100644
  #define JH7100_CLK_ENABLE     BIT(31)
 diff --git a/drivers/clk/starfive/clk-starfive-jh71x0.c b/drivers/clk/starfive/clk-starfive-jh71x0.c
 new file mode 100644
-index 000000000..6c07b61b4
+index 000000000000..6c07b61b4a32
 --- /dev/null
 +++ b/drivers/clk/starfive/clk-starfive-jh71x0.c
 @@ -0,0 +1,333 @@
@@ -759,5 +759,5 @@ index 000000000..6c07b61b4
 +}
 +EXPORT_SYMBOL_GPL(starfive_jh7100_clk_ops);
 -- 
-2.25.1
+2.20.1