jh71x0: refresh patches and configs once again
[openwrt/staging/wigyori.git] / target / linux / jh71x0 / patches-6.1 / 0013-clk-starfive-Add-StarFive-JH7110-system-clock-driver.patch
index 0a3d40623a4243b24556c5638d4924ef5e6784e2..1b56c4a4da050d36d2816ea58ec156de5983b169 100644 (file)
@@ -1,7 +1,7 @@
-From f1a94f6b2c1533d434a4411453b34d2a86647ff6 Mon Sep 17 00:00:00 2001
+From eea853275c704f6c24a418a50715bc5ad68a6283 Mon Sep 17 00:00:00 2001
 From: Emil Renner Berthing <kernel@esmil.dk>
 Date: Sat, 1 Apr 2023 19:19:25 +0800
-Subject: [PATCH 013/129] clk: starfive: Add StarFive JH7110 system clock
+Subject: [PATCH 013/122] clk: starfive: Add StarFive JH7110 system clock
  driver
 
 Add driver for the StarFive JH7110 system clock controller and
@@ -24,7 +24,7 @@ Signed-off-by: Conor Dooley <conor.dooley@microchip.com>
  create mode 100644 drivers/clk/starfive/clk-starfive-jh7110.h
 
 diff --git a/drivers/clk/starfive/Kconfig b/drivers/clk/starfive/Kconfig
-index 3ceeb19b5..670c5084a 100644
+index 3ceeb19b5eda..670c5084aeb8 100644
 --- a/drivers/clk/starfive/Kconfig
 +++ b/drivers/clk/starfive/Kconfig
 @@ -20,3 +20,14 @@ config CLK_STARFIVE_JH7100_AUDIO
@@ -43,7 +43,7 @@ index 3ceeb19b5..670c5084a 100644
 +        Say yes here to support the system clock controller on the
 +        StarFive JH7110 SoC.
 diff --git a/drivers/clk/starfive/Makefile b/drivers/clk/starfive/Makefile
-index 82edfa9f9..5ca4e887f 100644
+index 82edfa9f9cb8..5ca4e887fb9c 100644
 --- a/drivers/clk/starfive/Makefile
 +++ b/drivers/clk/starfive/Makefile
 @@ -3,3 +3,5 @@ obj-$(CONFIG_CLK_STARFIVE_JH71X0)      += clk-starfive-jh71x0.o
@@ -54,7 +54,7 @@ index 82edfa9f9..5ca4e887f 100644
 +obj-$(CONFIG_CLK_STARFIVE_JH7110_SYS) += clk-starfive-jh7110-sys.o
 diff --git a/drivers/clk/starfive/clk-starfive-jh7110-sys.c b/drivers/clk/starfive/clk-starfive-jh7110-sys.c
 new file mode 100644
-index 000000000..5ec210644
+index 000000000000..5ec210644e1d
 --- /dev/null
 +++ b/drivers/clk/starfive/clk-starfive-jh7110-sys.c
 @@ -0,0 +1,490 @@
@@ -550,7 +550,7 @@ index 000000000..5ec210644
 +builtin_platform_driver_probe(jh7110_syscrg_driver, jh7110_syscrg_probe);
 diff --git a/drivers/clk/starfive/clk-starfive-jh7110.h b/drivers/clk/starfive/clk-starfive-jh7110.h
 new file mode 100644
-index 000000000..f29682b8d
+index 000000000000..f29682b8d400
 --- /dev/null
 +++ b/drivers/clk/starfive/clk-starfive-jh7110.h
 @@ -0,0 +1,11 @@
@@ -566,5 +566,5 @@ index 000000000..f29682b8d
 +
 +#endif
 -- 
-2.25.1
+2.20.1