treewide: remove maintainer variable from targets
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 05a41beb4a60ae1ba6b31a4e3ea7c087130fffea..36e8af773f4b7e631b0df2131ca9ac9900d9bb14 100644 (file)
@@ -6,20 +6,17 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
-FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-LINUX_VERSION:=2.6.37.4
-
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-
-include $(INCLUDE_DIR)/target.mk
+KERNEL_PATCHVER:=4.19
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))