mips: use -mno-branch-likely for kernel and userspace, saves ~11k kernel size after...
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index 9623a0b4e5f53d2406b9b7ee7d990487278a005d..84958df7f65c027d55054c3d9ea6023a6e0e97fa 100644 (file)
@@ -6,15 +6,14 @@
 #
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY
+BOARDNAME:=Lantiq GPON/XWAY/SVIP
 FEATURES:=squashfs jffs2
-DEFAULT_SUBTARGET:=danube
+SUBTARGETS=xway ase falcon
 
-LINUX_VERSION:=3.2.14
+LINUX_VERSION:=3.7.1
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves -mno-branch-likely
 
 define Target/Description
        Build firmware images for Lantiq SoC