* update patches to 3.0
[openwrt/openwrt.git] / target / linux / lantiq / Makefile
index dfaccbb830925a029ec7e7947d88e03bb500d683..8d845b95a78afbb8005829051bb2c8f886ef9245 100644 (file)
@@ -10,16 +10,16 @@ ARCH:=mips
 BOARD:=lantiq
 BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
-SUBTARGETS:=falcon xway
+DEFAULT_SUBTARGET:=danube
 
-LINUX_VERSION:=2.6.37.4
+LINUX_VERSION:=3.0.3
 
-CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -funit-at-a-time
-
-include $(INCLUDE_DIR)/target.mk
+CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
 define Target/Description
        Build firmware images for Lantiq SoC
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 $(eval $(call BuildTarget))