target: use SPDX license identifiers on Makefiles
[openwrt/staging/wigyori.git] / target / linux / lantiq / Makefile
index d7f75683e07ef4b5576db665a6cc422837dbd461..fc8aad4265ba678594f16a1883308d42e57abfe8 100644 (file)
@@ -1,19 +1,15 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2007-2011 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 BOARD:=lantiq
-BOARDNAME:=Lantiq GPON/XWAY/SVIP
-FEATURES:=squashfs ubifs
-SUBTARGETS=xway xrx200 ase falcon
-
-LINUX_VERSION:=3.10.34
+BOARDNAME:=Lantiq
+FEATURES:=squashfs
+SUBTARGETS:=xrx200 xway xway_legacy falcon ase
 
-CPU_TYPE:=mips32r2
+KERNEL_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Lantiq SoC