lantiq: add Falcon support
[openwrt/openwrt.git] / target / linux / lantiq / falcon / target.mk
diff --git a/target/linux/lantiq/falcon/target.mk b/target/linux/lantiq/falcon/target.mk
new file mode 100644 (file)
index 0000000..b87d1dc
--- /dev/null
@@ -0,0 +1,13 @@
+ARCH:=mips
+SUBTARGET:=falcon
+BOARDNAME:=Falcon
+FEATURES:=squashfs mips16 nand
+CPU_TYPE:=24kc
+
+DEFAULT_PACKAGES+= kmod-leds-gpio \
+       kmod-gpio-button-hotplug \
+       kmod-ledtrig-heartbeat
+
+define Target/Description
+       Lantiq Falcon
+endef