add support for more lantiq AR9 boards
[openwrt/svn-archive/archive.git] / target / linux / lantiq / image / Makefile
index b1ef0a5cde623325c107d7ab5fe9223e33ede18a..8c607b21517b17883925620f3f11d744aaf8c31e 100644 (file)
@@ -9,7 +9,7 @@ include $(INCLUDE_DIR)/image.mk
 
 JFFS2_BLOCKSIZE = 64k 128k 256k
 
-ase_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
+ase_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
 xway_cmdline=-console=ttyLTQ1,115200 rootfstype=squashfs,jffs2
 falcon_cmdline=-console=ttyLTQ0,115200 rootfstype=squashfs,jffs2
 
@@ -55,7 +55,7 @@ define Image/BuildKernel/Template
        $(CP) $(KDIR)/uImage-$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1)-uImage
 endef
 
-ifeq ($(CONFIG_TARGET_lantiq_xway),y)
+ifeq ($(CONFIG_TARGET_lantiq_danube),y)
 define Image/BuildKernel/Profile/EASY50712
        $(call Image/BuildKernel/Template,EASY50712,$(xway_cmdline))
 endef
@@ -112,6 +112,14 @@ define Image/Build/Profile/ARV4525PW
        $(call Image/Build/$(1),$(1),ARV4525PW)
 endef
 
+define Image/BuildKernel/Profile/ARV7525PW
+       $(call Image/BuildKernel/Template,ARV7525PW,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/ARV7525PW
+       $(call Image/Build/$(1),$(1),ARV7525PW)
+endef
+
 define Image/BuildKernel/Profile/ARV452CPW
        $(call Image/BuildKernel/Template,ARV452CPW,$(xway_cmdline))
 endef
@@ -128,20 +136,20 @@ define Image/Build/Profile/ARV7518PW
        $(call Image/Build/$(1),$(1),ARV7518PW)
 endef
 
-define Image/BuildKernel/Profile/ARV752DPW22
-       $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
+define Image/BuildKernel/Profile/ARV752DPW
+       $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
 endef
 
-define Image/Build/Profile/ARV752DPW22
-       $(call Image/Build/$(1),$(1),ARV752DPW22)
+define Image/Build/Profile/ARV752DPW
+       $(call Image/Build/$(1),$(1),ARV752DPW)
 endef
 
-define Image/BuildKernel/Profile/DGN3500B
-       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+define Image/BuildKernel/Profile/ARV752DPW22
+       $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
 endef
 
-define Image/Build/Profile/DGN3500B
-       $(call Image/Build/$(1),$(1),DGN3500B)
+define Image/Build/Profile/ARV752DPW22
+       $(call Image/Build/$(1),$(1),ARV752DPW22)
 endef
 
 define Image/BuildKernel/Profile/GIGASX76X
@@ -162,11 +170,11 @@ define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,ARV4520PW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV452CPW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV4525PW,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,ARV7525PW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV7518PW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV752DPW,$(xway_cmdline))
        $(call Image/BuildKernel/Template,ARV752DPW22,$(xway_cmdline))
        $(call Image/BuildKernel/Template,GIGASX76X,$(xway_cmdline))
-       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
        $(call Image/BuildKernel/Template,NONE)
 endef
 
@@ -180,10 +188,41 @@ define Image/Build/Profile/Generic
        $(call Image/Build/$(1),$(1),ARV4520PW)
        $(call Image/Build/$(1),$(1),ARV452CPW)
        $(call Image/Build/$(1),$(1),ARV4525PW)
+       $(call Image/Build/$(1),$(1),ARV7525PW)
        $(call Image/Build/$(1),$(1),ARV7518PW)
        $(call Image/Build/$(1),$(1),ARV752DPW)
        $(call Image/Build/$(1),$(1),ARV752DPW22)
        $(call Image/Build/$(1),$(1),GIGASX76X)
+       $(call Image/Build/$(1),$(1),NONE)
+       $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
+endef
+endif
+
+ifeq ($(CONFIG_TARGET_lantiq_ar9),y)
+define Image/BuildKernel/Profile/WBMR
+       $(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/WBMR
+       $(call Image/Build/$(1),$(1),WBMR)
+endef
+
+define Image/BuildKernel/Profile/DGN3500B
+       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+endef
+
+define Image/Build/Profile/DGN3500B
+       $(call Image/Build/$(1),$(1),DGN3500B)
+endef
+
+define Image/BuildKernel/Profile/Generic
+       $(call Image/BuildKernel/Template,WBMR,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,DGN3500B,$(xway_cmdline))
+       $(call Image/BuildKernel/Template,NONE)
+endef
+
+define Image/Build/Profile/Generic
+       $(call Image/Build/$(1),$(1),WBMR)
        $(call Image/Build/$(1),$(1),DGN3500B)
        $(call Image/Build/$(1),$(1),NONE)
        $(CP) $(KDIR)/root.$(1) $(BIN_DIR)/$(IMG_PREFIX)-$(1).rootfs
@@ -191,6 +230,22 @@ endef
 endif
 
 ifeq ($(CONFIG_TARGET_lantiq_falcon)$(CONFIG_TARGET_lantiq_falcon_stable),y)
+define Image/BuildKernel/Profile/EASY98000
+       $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
+endef
+
+define Image/Build/Profile/EASY98000
+       $(call Image/Build/$(1),$(1),EASY98000)
+endef
+
+define Image/BuildKernel/Profile/EASY98020
+       $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))
+endef
+
+define Image/Build/Profile/EASY98020
+       $(call Image/Build/$(1),$(1),EASY98020)
+endef
+
 define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
        $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))