lantiq: Refresh patches and configuration
[openwrt/openwrt.git] / target / linux / lantiq / patches-6.1 / 0001-MIPS-lantiq-add-pcie-driver.patch
index 6454240014e7987e3d52b22039ce2ff7a2635126..b8f3116bb43c4b8b1c52e6784e4fff24f68f2e55 100644 (file)
@@ -65,15 +65,15 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  endif
 --- a/arch/mips/pci/Makefile
 +++ b/arch/mips/pci/Makefile
-@@ -43,6 +43,8 @@ obj-$(CONFIG_PCI_LANTIQ)     += pci-lantiq.o
+@@ -41,6 +41,8 @@ obj-$(CONFIG_PCI_LANTIQ)     += pci-lantiq.o
  obj-$(CONFIG_SOC_MT7620)      += pci-mt7620.o
  obj-$(CONFIG_SOC_RT288X)      += pci-rt2880.o
  obj-$(CONFIG_SOC_RT3883)      += pci-rt3883.o
 +obj-$(CONFIG_PCIE_LANTIQ)     += ifxmips_pcie_phy.o ifxmips_pcie.o fixup-lantiq-pcie.o
 +obj-$(CONFIG_PCIE_LANTIQ_MSI) += pcie-lantiq-msi.o
- obj-$(CONFIG_TANBAC_TB0219)   += fixup-tb0219.o
- obj-$(CONFIG_TANBAC_TB0226)   += fixup-tb0226.o
- obj-$(CONFIG_TANBAC_TB0287)   += fixup-tb0287.o
+ obj-$(CONFIG_SOC_TX4927)      += pci-tx4927.o
+ obj-$(CONFIG_SOC_TX4938)      += pci-tx4938.o
+ obj-$(CONFIG_TOSHIBA_RBTX4927)        += fixup-rbtx4927.o
 --- /dev/null
 +++ b/arch/mips/pci/fixup-lantiq-pcie.c
 @@ -0,0 +1,74 @@
@@ -5524,8 +5524,8 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
          (transaction layer end-to-end CRC checking).
 --- a/include/linux/pci.h
 +++ b/include/linux/pci.h
-@@ -1483,6 +1483,8 @@ void pci_walk_bus(struct pci_bus *top, i
-                 void *userdata);
+@@ -1558,6 +1558,8 @@ void pci_walk_bus_locked(struct pci_bus
+                        void *userdata);
  int pci_cfg_space_size(struct pci_dev *dev);
  unsigned char pci_bus_max_busnr(struct pci_bus *bus);
 +int pcibios_host_nr(void);
@@ -5535,7 +5535,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                                         unsigned long type);
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -1086,6 +1086,12 @@
+@@ -1097,6 +1097,12 @@
  #define PCI_DEVICE_ID_SGI_IOC3                0x0003
  #define PCI_DEVICE_ID_SGI_LITHIUM     0x1002