layerscape: rename subtargets and update makefile files
[openwrt/staging/lynxis.git] / target / linux / layerscape / Makefile
index 3def184b948bde18b7d5b6533797e9cc8b8d8d51..c2d3cc07afb9d772b74e3c612e8c58a3e72a7c9e 100644 (file)
@@ -12,15 +12,15 @@ DEVICE_TYPE:=developerboard
 KERNEL_PATCHVER:=4.4
 KERNELNAME:=Image dtbs
 FEATURES:=squashfs nand usb pcie gpio
-SUBTARGETS:=64b 32b
+SUBTARGETS:=armv8_64b armv8_32b
 MAINTAINER:=Yangbo Lu <yangbo.lu@nxp.com>
 
-include $(INCLUDE_DIR)/target.mk
-
 define Target/Description
-       Build firmware images for $(BOARDNAME) SoC devices.
+       Build firmware images for NXP Layerscape based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
 DEFAULT_PACKAGES += kmod-usb3 kmod-usb-dwc3 kmod-usb-storage
 
 $(eval $(call BuildTarget))