add preliminary LEON support
[openwrt/openwrt.git] / target / linux / leon / Makefile
diff --git a/target/linux/leon/Makefile b/target/linux/leon/Makefile
new file mode 100644 (file)
index 0000000..eb3b83f
--- /dev/null
@@ -0,0 +1,22 @@
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+ARCH:=sparc
+BOARD:=leon
+BOARDNAME:=LEON
+FEATURES+=fpu tgz
+
+CFLAGS:=-Os -pipe -mcpu=v8 -funit-at-a-time
+KERNELNAME:="uImage"
+
+LINUX_VERSION:=2.6.36.2
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+
+include $(INCLUDE_DIR)/target.mk
+
+$(eval $(call BuildTarget))