global cflags: remove -funit-at-a-time, it is ignored by recent compilers. instead...
[openwrt/staging/yousong.git] / target / linux / mpc52xx / Makefile
index 35930bc2a9ceecf664e889ddc3cc8f3016b83bf6..3d9c4701776a314967454c25013a0f8f928ecd32 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2009 OpenWrt.org
+# Copyright (C) 2009-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,10 +9,10 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc52xx
 BOARDNAME:=Freescale MPC52xx
-FEATURES:=tgz ext2
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=603e
+FEATURES:=targz ext4
 
 LINUX_VERSION:=2.6.30.10
-LINUX_KARCH:=powerpc
 
 include $(INCLUDE_DIR)/target.mk