mpc83xx: add kernel 2.6.35 preliminary support
[openwrt/staging/jogo.git] / target / linux / mpc83xx / patches-2.6.35 / 019-powerpc_create_fit_uImages.patch
diff --git a/target/linux/mpc83xx/patches-2.6.35/019-powerpc_create_fit_uImages.patch b/target/linux/mpc83xx/patches-2.6.35/019-powerpc_create_fit_uImages.patch
new file mode 100644 (file)
index 0000000..251a053
--- /dev/null
@@ -0,0 +1,94 @@
+--- a/arch/powerpc/Makefile
++++ b/arch/powerpc/Makefile
+@@ -157,7 +157,8 @@ drivers-$(CONFIG_OPROFILE) += arch/power
+ # Default to zImage, override when needed
+ all: zImage
+-BOOT_TARGETS = zImage zImage.initrd uImage zImage% dtbImage% treeImage.% cuImage.% simpleImage.%
++BOOT_TARGETS = zImage zImage.initrd uImage uImage.fit.% zImage% dtbImage% \
++             treeImage.% cuImage.% simpleImage.%
+ PHONY += $(BOOT_TARGETS)
+@@ -184,6 +185,7 @@ define archhelp
+   @echo '* zImage          - Build default images selected by kernel config'
+   @echo '  zImage.*        - Compressed kernel image (arch/$(ARCH)/boot/zImage.*)'
+   @echo '  uImage          - U-Boot native image format'
++  @echo '  uImage.fit.<dt> - U-Boot Flattened Image Tree image format'
+   @echo '  cuImage.<dt>    - Backwards compatible U-Boot image for older'
+   @echo '                    versions which do not support device trees'
+   @echo '  dtbImage.<dt>   - zImage with an embedded device tree blob'
+--- a/arch/powerpc/boot/.gitignore
++++ b/arch/powerpc/boot/.gitignore
+@@ -19,6 +19,7 @@ kernel-vmlinux.strip.c
+ kernel-vmlinux.strip.gz
+ mktree
+ uImage
++uImage.fit.*
+ cuImage.*
+ dtbImage.*
+ treeImage.*
+--- a/arch/powerpc/boot/Makefile
++++ b/arch/powerpc/boot/Makefile
+@@ -311,6 +311,9 @@ $(obj)/zImage.iseries: vmlinux
+ $(obj)/uImage: vmlinux $(wrapperbits)
+       $(call if_changed,wrap,uboot)
++$(obj)/uImage.fit.%: vmlinux $(obj)/%.dtb $(wrapperbits)
++      $(call if_changed,wrap,uboot.fit,,$(obj)/$*.dtb)
++
+ $(obj)/cuImage.initrd.%: vmlinux $(obj)/%.dtb $(wrapperbits)
+       $(call if_changed,wrap,cuboot-$*,,$(obj)/$*.dtb,$(obj)/ramdisk.image.gz)
+@@ -350,7 +353,7 @@ install: $(CONFIGURE) $(addprefix $(obj)
+ # anything not in $(targets)
+ clean-files += $(image-) $(initrd-) cuImage.* dtbImage.* treeImage.* \
+-      zImage zImage.initrd zImage.chrp zImage.coff zImage.holly \
++      uImage.* zImage zImage.initrd zImage.chrp zImage.coff zImage.holly \
+       zImage.iseries zImage.miboot zImage.pmac zImage.pseries \
+       simpleImage.* otheros.bld *.dtb
+--- a/arch/powerpc/boot/wrapper
++++ b/arch/powerpc/boot/wrapper
+@@ -46,6 +46,9 @@ CROSS=
+ # mkimage wrapper script
+ MKIMAGE=$srctree/scripts/mkuboot.sh
++# script to generate an .its file for uImage.fit.* images
++MKITS=$srctree/scripts/mkits.sh
++
+ # directory for object and other files used by this script
+ object=arch/powerpc/boot
+ objbin=$object
+@@ -157,7 +160,7 @@ coff)
+     lds=$object/zImage.coff.lds
+     link_address='0x500000'
+     ;;
+-miboot|uboot)
++miboot|uboot|uboot.fit)
+     # miboot and U-boot want just the bare bits, not an ELF binary
+     ext=bin
+     objflags="-O binary"
+@@ -275,6 +278,21 @@ uboot)
+     if [ -z "$cacheit" ]; then
+       rm -f "$vmz"
+     fi
++    exit 0
++    ;;
++uboot.fit)
++    rm -f "$ofile"
++    ${MKITS} -A ppc -C gzip -a $membase -e $membase -v $version \
++      -d "$srctree/$dtb" -k "$srctree/$vmz" -o "$object/uImage.its"
++
++    # mkimage calls dtc for FIT images so use kernel dtc if necessary
++    export PATH=$PATH:$srctree/scripts/dtc
++
++    ${MKIMAGE} -f "$object/uImage.its" "$ofile"
++    rm "$object/uImage.its"
++    if [ -z "$cacheit" ]; then
++      rm -f "$vmz"
++    fi
+     exit 0
+     ;;
+ esac