kernel: update linux 3.8 to 3.8.6
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index 96e7763129ab82daff8e67bc10d6523363d4e2af..1559c669f802c2299d0cfdc2c0f1fc520503fdd1 100644 (file)
@@ -9,14 +9,19 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
-FEATURES:=fpu ramdisk broken
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.1
+LINUX_VERSION:=3.8.6
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef