kernel: update linux 3.3 to 3.3.6
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index ef67446f937dd70ced53d61cf8fe5a67773eea88..270ac229f5425271b69603fb41f5ba2893f01ec3 100644 (file)
@@ -9,14 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
-CFLAGS:=-Os -pipe -funit-at-a-time -mcpu=8540
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
 FEATURES:=spe_fpu ramdisk broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.36.4
+LINUX_VERSION:=3.3.6
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += kmod-booke-wdt
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef