kernel: update 3.10 to 3.10.3
[openwrt/openwrt.git] / target / linux / mpc85xx / Makefile
index d32a58ef23c2d31003d0a8ceda81639c2a0f19ec..5a9e7ac6a140389283048713231b4f239dbe5833 100644 (file)
@@ -10,13 +10,19 @@ ARCH:=powerpc
 BOARD:=mpc85xx
 BOARDNAME:=Freescale MPC85xx
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=8540
-FEATURES:=spe_fpu ramdisk
+FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
+SUBTARGETS=generic p1020
 
-LINUX_VERSION:=2.6.38.2
+LINUX_VERSION:=3.10.3
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += \
+       kmod-input-core kmod-input-gpio-keys kmod-button-hotplug \
+       kmod-leds-gpio kmod-booke-wdt \
+       swconfig kmod-ath9k wpad-mini
+
 define Target/Description
        Build images for the Freescale MPC85xx based boards.
 endef