mpc85xx: update to linux 4.4, remove unnecessary patches
[openwrt/openwrt.git] / target / linux / mpc85xx / patches-3.18 / 140-powerpc-85xx-tl-wdr4900-v1-support.patch
diff --git a/target/linux/mpc85xx/patches-3.18/140-powerpc-85xx-tl-wdr4900-v1-support.patch b/target/linux/mpc85xx/patches-3.18/140-powerpc-85xx-tl-wdr4900-v1-support.patch
deleted file mode 100644 (file)
index 9b4815c..0000000
+++ /dev/null
@@ -1,78 +0,0 @@
-From 406d86e5990ac171f18ef6e2973672d8fbfe1556 Mon Sep 17 00:00:00 2001
-From: Gabor Juhos <juhosg@openwrt.org>
-Date: Wed, 20 Feb 2013 08:40:33 +0100
-Subject: [PATCH] powerpc: 85xx: add support for the TP-Link TL-WDR4900 v1
- board
-
-This patch adds support for the TP-Link TL-WDR4900 v1
-concurrent dual-band wireless router. The devices uses
-the Freescale P1014 SoC.
-
-Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
----
- arch/powerpc/boot/Makefile                  |   3 +
- arch/powerpc/boot/wrapper                   |   4 +
- arch/powerpc/platforms/85xx/Kconfig         |  11 ++
- arch/powerpc/platforms/85xx/Makefile        |   1 +
-
---- a/arch/powerpc/boot/Makefile
-+++ b/arch/powerpc/boot/Makefile
-@@ -112,6 +112,7 @@ src-plat-$(CONFIG_PPC_POWERNV) += pserie
- src-plat-$(CONFIG_PPC_IBM_CELL_BLADE) += pseries-head.S
- src-plat-$(CONFIG_PPC_CELLEB) += pseries-head.S
- src-plat-$(CONFIG_PPC_CELL_QPACE) += pseries-head.S
-+src-plat-$(CONFIG_TL_WDR4900_V1) += cuboot-tl-wdr4900-v1.c
- src-wlib := $(sort $(src-wlib-y))
- src-plat := $(sort $(src-plat-y))
-@@ -296,6 +297,7 @@ image-$(CONFIG_TQM8555)                    += cuImage.tqm
- image-$(CONFIG_TQM8560)                       += cuImage.tqm8560
- image-$(CONFIG_SBC8548)                       += cuImage.sbc8548
- image-$(CONFIG_KSI8560)                       += cuImage.ksi8560
-+image-$(CONFIG_TL_WDR4900_V1)         += cuImage.tl-wdr4900-v1
- # Board ports in arch/powerpc/platform/embedded6xx/Kconfig
- image-$(CONFIG_STORCENTER)            += cuImage.storcenter
---- a/arch/powerpc/boot/wrapper
-+++ b/arch/powerpc/boot/wrapper
-@@ -218,6 +218,10 @@ cuboot*)
-     *-mpc85*|*-tqm85*|*-sbc85*)
-         platformo=$object/cuboot-85xx.o
-         ;;
-+    *-tl-wdr4900-v1)
-+        platformo=$object/cuboot-tl-wdr4900-v1.o
-+      link_address='0x1000000'
-+        ;;
-     *-amigaone)
-         link_address='0x800000'
-         ;;
---- a/arch/powerpc/platforms/85xx/Kconfig
-+++ b/arch/powerpc/platforms/85xx/Kconfig
-@@ -168,6 +168,17 @@ config STX_GP3
-       select CPM2
-       select DEFAULT_UIMAGE
-+config TL_WDR4900_V1
-+      bool "TP-Link TL-WDR4900 v1"
-+      select DEFAULT_UIMAGE
-+      select ARCH_REQUIRE_GPIOLIB
-+      select GPIO_MPC8XXX
-+      help
-+        This option enables support for the TP-Link TL-WDR4900 v1 board.
-+
-+        This board is a Concurrent Dual-Band wireless router with a
-+        Freescale P1014 SoC.
-+
- config TQM8540
-       bool "TQ Components TQM8540"
-       help
---- a/arch/powerpc/platforms/85xx/Makefile
-+++ b/arch/powerpc/platforms/85xx/Makefile
-@@ -23,6 +23,7 @@ obj-$(CONFIG_TWR_P102x)   += twr_p102x.o
- obj-$(CONFIG_CORENET_GENERIC)   += corenet_generic.o
- obj-$(CONFIG_STX_GP3)   += stx_gp3.o
- obj-$(CONFIG_TQM85xx)   += tqm85xx.o
-+obj-$(CONFIG_TL_WDR4900_V1) += tl_wdr4900_v1.o
- obj-$(CONFIG_SBC8548)     += sbc8548.o
- obj-$(CONFIG_PPA8548)     += ppa8548.o
- obj-$(CONFIG_SOCRATES)    += socrates.o socrates_fpga_pic.o