mpc85xx: remove 5.15 support
[openwrt/openwrt.git] / target / linux / mpc85xx / patches-5.15 / 900-powerpc-bootwrapper-disable-uImage-generation.patch
diff --git a/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch b/target/linux/mpc85xx/patches-5.15/900-powerpc-bootwrapper-disable-uImage-generation.patch
deleted file mode 100644 (file)
index 7f99bd5..0000000
+++ /dev/null
@@ -1,42 +0,0 @@
-From d43ab14605510d9d2bd257a8cd70f24ada4621b0 Mon Sep 17 00:00:00 2001
-From: David Bauer <mail@david-bauer.net>
-Date: Sat, 29 Feb 2020 14:27:04 +0100
-Subject: [PATCH] powerpc: bootwrapper: disable uImage generation
-
-Due to CONFIG_KERNEL_XZ symbol, the bootwrapper code tries to
-instruct the mkimage to use the xz compression, which isn't
-supported. This disables the uImage generation, as OpenWrt
-generates individual uImages for each board using it's own
-toolchain.
-
-Signed-off-by: David Bauer <mail@david-bauer.net>
----
- arch/powerpc/boot/Makefile | 9 ---------
- 1 file changed, 9 deletions(-)
-
---- a/arch/powerpc/boot/Makefile
-+++ b/arch/powerpc/boot/Makefile
-@@ -275,7 +275,6 @@ image-$(CONFIG_PPC_CHRP)           += zImage.chrp
- image-$(CONFIG_PPC_EFIKA)             += zImage.chrp
- image-$(CONFIG_PPC_PMAC)              += zImage.pmac
- image-$(CONFIG_PPC_HOLLY)             += dtbImage.holly
--image-$(CONFIG_DEFAULT_UIMAGE)                += uImage
- image-$(CONFIG_EPAPR_BOOT)            += zImage.epapr
- #
-@@ -411,15 +410,6 @@ $(obj)/dtbImage.%: vmlinux $(wrapperbits
- $(obj)/vmlinux.strip: vmlinux
-       $(STRIP) -s -R .comment $< -o $@
--$(obj)/uImage: vmlinux $(wrapperbits) FORCE
--      $(call if_changed,wrap,uboot)
--
--$(obj)/uImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
--      $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)
--
--$(obj)/uImage.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
--      $(call if_changed,wrap,uboot-$*,,$(obj)/dts/$*.dtb)
--
- $(obj)/cuImage.initrd.%: vmlinux $(obj)/dts/%.dtb $(wrapperbits) FORCE
-       $(call if_changed,wrap,cuboot-$*,,$(obj)/dts/$*.dtb,$(obj)/ramdisk.image.gz)