mpc85xx: add profile and build image for the TL-WDR4900 v1 board
[openwrt/staging/hauke.git] / target / linux / mpc85xx / profiles / tp-link.mk
diff --git a/target/linux/mpc85xx/profiles/tp-link.mk b/target/linux/mpc85xx/profiles/tp-link.mk
new file mode 100644 (file)
index 0000000..57981d3
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/TLWDR4900
+       NAME:=TP-Link TL-WDR4900
+       PACKAGES:=\
+               kmod-usb-core kmod-usb2 kmod-usb2-fsl \
+               kmod-ath9k kmod-wpad
+endef
+
+define Profile/TLWDR4900/Description
+       Package set optimized for the TP-Link TL-WDR4900.
+endef
+$(eval $(call Profile,TLWDR4900))