treewide: simplify inclusion of subtarget image files
[openwrt/staging/stintel.git] / target / linux / mvebu / image / Makefile
index 3a478780693d31023fae0a62b2152c3dc4e79ce7..cbf34c1bc86e16930c0ed4c9316c5c62f42e1244 100644 (file)
@@ -138,16 +138,6 @@ define Device/NAND-512K
   PAGESIZE := 4096
 endef
 
-ifeq ($(SUBTARGET),cortexa9)
-include cortexa9.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa53)
-include cortexa53.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa72)
-include cortexa72.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))