mvebu: add initial support for Globalscale ESPRESSObin-Ultra
[openwrt/openwrt.git] / target / linux / mvebu / image / cortexa53.mk
index b65f25472c007ece3aaf74614309434edcd26b6e..6a3a5686553c3be1c678bbb5fce33b0c0f1f9c45 100644 (file)
@@ -32,6 +32,17 @@ define Device/globalscale_espressobin-emmc
 endef
 TARGET_DEVICES += globalscale_espressobin-emmc
 
+define Device/globalscale_espressobin-ultra
+  $(call Device/Default-arm64)
+  DEVICE_VENDOR := Marvell
+  DEVICE_MODEL := ESPRESSObin
+  DEVICE_VARIANT := Ultra
+  DEVICE_PACKAGES += kmod-i2c-pxa kmod-rtc-pcf8563
+  SOC := armada-3720
+  BOOT_SCRIPT := espressobin
+endef
+TARGET_DEVICES += globalscale_espressobin-ultra
+
 define Device/globalscale_espressobin-v7
   $(call Device/Default-arm64)
   DEVICE_VENDOR := Marvell