target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / mxs / image / Makefile
index f0f1f6acf3da14915372db5e9e009d7ad7361316..bcb6001bac26abbccf4bbaded2136fb65f7cae73 100644 (file)
@@ -1,9 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013-2015 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
@@ -40,7 +37,7 @@ define Image/Build/SDCard-vfat-ext4
 
        ./gen_sdcard_vfat_ext4.sh \
                $(BIN_DIR)/$(2) \
-               $(KDIR)/$(4)-u-boot.sb \
+               $(STAGING_DIR_IMAGE)/$(4)-u-boot.sb \
                $(KDIR)/boot.img \
                $(KDIR)/root.$(1) \
                $(CONFIG_TARGET_BOOTFS_PARTSIZE) \
@@ -51,7 +48,7 @@ endef
 define Image/Build/SDCard-ext4-ext4
        ./gen_sdcard_ext4_ext4.sh \
                $(BIN_DIR)/$(2) \
-               $(KDIR)/$(4)-u-boot.sb \
+               $(STAGING_DIR_IMAGE)/$(4)-u-boot.sb \
                $(KDIR)/root.$(1) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE)
        $(call Image/Gzip,$(BIN_DIR)/$(2))