mxs: build/profile-related changes - change uImage creation to use zImage - update...
[openwrt/staging/yousong.git] / target / linux / mxs / profiles / 01-olinuxino-maxi.mk
diff --git a/target/linux/mxs/profiles/01-olinuxino-maxi.mk b/target/linux/mxs/profiles/01-olinuxino-maxi.mk
new file mode 100644 (file)
index 0000000..408d26d
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/olinuxino-maxi
+  NAME:=Olimex OLinuXino MAXI/MINI boards
+  PACKAGES += imx-bootlets uboot-mxs-mx23_olinuxino \
+         kmod-usb-mxs-phy kmod-usb-net kmod-usb-net-smsc95xx \
+         kmod-gpio-mcp23s08 kmod-leds-gpio kmod-ledtrig-heartbeat kmod-rtc-stmp3xxx \
+         kmod-sound-core kmod-sound-soc-mxs kmod-iio-mxs-lradc kmod-crypto-hw-dcp
+endef
+
+define Profile/olinuxino-maxi/Description
+       Olimex OLinuXino MAXI/MINI boards
+endef
+$(eval $(call Profile,olinuxino-maxi))
+