mxs: add support for I2SE Duckbill devices
[openwrt/svn-archive/archive.git] / target / linux / mxs / profiles / 02-duckbill.mk
diff --git a/target/linux/mxs/profiles/02-duckbill.mk b/target/linux/mxs/profiles/02-duckbill.mk
new file mode 100644 (file)
index 0000000..847460a
--- /dev/null
@@ -0,0 +1,20 @@
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/duckbill
+  NAME:=I2SE Duckbill series
+  DEPENDS:=+@TARGET_ROOTFS_INCLUDE_KERNEL +@TARGET_ROOTFS_INCLUDE_DTB
+  PACKAGES+= \
+       -dnsmasq -firewall -ppp -ip6tables -iptables -6relayd -mtd uboot-envtools \
+       kmod-leds-gpio kmod-ledtrig-timer kmod-usb-mxs-phy -kmod-ipt-nathelper
+endef
+
+define Profile/duckbill/Description
+       I2SE's Duckbill devices
+endef
+
+$(eval $(call Profile,duckbill))