target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / octeon / Makefile
index 3cf814866cc85a4512bca55342c5eab48a90d4c8..5c4c12a4ef1b5dce56634be725cd15061a8de9c6 100644 (file)
@@ -1,25 +1,24 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2009 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2013 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
-ARCH:=mips
+ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci
-CFLAGS:=-Os -pipe -funit-at-a-time
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
 
-LINUX_VERSION:=2.6.30-rc7
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += hostapd-mini
+KERNEL_PATCHVER:=5.4
+KERNEL_TESTING_PATCHVER:=5.4
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))