dnsmasq: full: disable ipset support by default
[openwrt/staging/mkresin.git] / target / linux / octeon / Makefile
index afef2ba67e7714d98167a2533808ca4af61fd2f2..beb3e5436ad1b53f74672d2dd51f9022bed18b1b 100644 (file)
@@ -1,19 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs ext4 initramfs pci usb
-CPU_TYPE:=octeon
-MAINTAINER:=John Crispin <john@phrozen.org>
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
 
-KERNEL_PATCHVER:=4.4
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
@@ -21,4 +19,6 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))