dnsmasq: full: disable ipset support by default
[openwrt/staging/mkresin.git] / target / linux / octeon / Makefile
index f4fd9da79b75d9759ca6274ff4ac474daf6822e5..beb3e5436ad1b53f74672d2dd51f9022bed18b1b 100644 (file)
@@ -1,26 +1,24 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=mips64
 BOARD:=octeon
 BOARDNAME:=Cavium Networks Octeon
-FEATURES:=squashfs jffs2 pci usb
-CPU_TYPE:=octeon
-CPU_CFLAGS_octeon:=-march=octeon -mabi=64
-MAINTAINER:=John Crispin <blogic@openwrt.org>
-
-LINUX_VERSION:=3.10.36
-
-include $(INCLUDE_DIR)/target.mk
+FEATURES:=squashfs ramdisk pci usb
+CPU_TYPE:=octeonplus
 
+KERNEL_PATCHVER:=5.10
+KERNEL_TESTING_PATCHVER:=5.15
 
 define Target/Description
        Build firmware images for Cavium Networks Octeon-based boards.
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))