omap: make use of 'rootfs-part' feature
[openwrt/staging/chunkeey.git] / target / linux / omap / Makefile
index f58197fdc941cde4ae765c5785f4ff9cb4a7893a..c7a904bbe58984e6d38e12501efb7fc77b01e679 100644 (file)
@@ -1,21 +1,17 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2012-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand rootfs-part squashfs
 CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 
-KERNEL_PATCHVER:=4.4
-
-MAINTAINER:=Alexander Couzens <lynxis@fe80.eu>
+KERNEL_PATCHVER:=5.10
 
 KERNELNAME:=zImage dtbs
 
@@ -25,6 +21,6 @@ endef
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))