ath79: update WA/XC devices UBNT_VERSION to 8.7.4
[openwrt/staging/wigyori.git] / target / linux / omap / Makefile
index 3496018306e83ca44cfd1e8b3c7400992a4c12b2..fc0842d056e4486adc7684342f5dc0aa94dccc45 100644 (file)
@@ -1,32 +1,27 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
-# Copyright (C) 2012-2013 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+# Copyright (C) 2012-2014 OpenWrt.org
+
 include $(TOPDIR)/rules.mk
 
 ARCH:=arm
 BOARD:=omap
 BOARDNAME:=TI OMAP3/4/AM33xx
-FEATURES:=usb usbgadget ext4 targz fpu audio display
-CPU_TYPE:=cortex-a9
+FEATURES:=usb usbgadget ext4 targz fpu audio display nand rootfs-part squashfs source-only
+CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
+SUBTARGETS:=generic
 
-LINUX_VERSION:=3.12
+KERNEL_PATCHVER:=6.1
 
-MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
-
-KERNELNAME:="zImage dtbs"
-
-include $(INCLUDE_DIR)/target.mk
-
-DEFAULT_PACKAGES += uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
-
-DEVICE_TYPE=developerboard
+KERNELNAME:=zImage dtbs
 
 define Target/Description
        TI OMAP boards
 endef
 
+include $(INCLUDE_DIR)/target.mk
+
+DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
+
 $(eval $(call BuildTarget))