target: use SPDX license identifiers on Makefiles
[openwrt/openwrt.git] / target / linux / omap / image / Makefile
index 106071a38ed8044f6947351d8fada69b91510d21..10c6d0ad684ced9588194585f86e1a78162e6c3b 100644 (file)
@@ -1,9 +1,7 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2012-2014 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
+
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
@@ -33,12 +31,11 @@ endef
 
 define Device/Default
   PROFILES := Default
-  DEVICE_VARS :=
   KERNEL_NAME := zImage
   KERNEL := kernel-bin
+  DEVICE_DTS = $(lastword $(subst _, ,$(1)))
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := omap-sdcard | append-metadata | gzip
-  SUPPORTED_DEVICES = $(subst _,$(comma),$(1))
 endef
 
 #uboot-omap-am335x_evm uboot-omap-omap3_beagle uboot-omap-omap3_overo uboot-omap-omap4_panda
@@ -46,7 +43,6 @@ endef
 define Device/ti_am335x-evm
   DEVICE_VENDOR := Texas Instruments
   DEVICE_MODEL := AM335x EVM
-  DEVICE_DTS := am335x-evm
 endef
 
 TARGET_DEVICES += ti_am335x-evm
@@ -62,7 +58,6 @@ TARGET_DEVICES += ti_am335x-bone-black
 define Device/ti_omap4-panda
   DEVICE_VENDOR := PandaBoard.org
   DEVICE_MODEL := OMAP4 TI pandaboard
-  DEVICE_DTS := omap4-panda
   DEVICE_PACKAGES := kmod-usb-net-smsc95xx
 endef
 
@@ -71,9 +66,8 @@ TARGET_DEVICES += ti_omap4-panda
 define Device/ti_omap3-beagle
   DEVICE_VENDOR := BeagleBoard.org
   DEVICE_MODEL := OMAP3 TI beagleboard
-  DEVICE_DTS := omap3-beagle
   # beagleboard doesn't have a network interface, support most common usb net
-  DEVICE_PACKAGES := kmod-usb-net \
+  DEVICE_PACKAGES := \
        kmod-usb-net-asix kmod-usb-net-asix-ax88179 kmod-usb-net-hso \
        kmod-usb-net-kaweth kmod-usb-net-pegasus kmod-usb-net-mcs7830 \
        kmod-usb-net-smsc95xx kmod-usb-net-dm9601-ether