mark 3.10 targets as broken
[openwrt/svn-archive/archive.git] / target / linux / orion / Makefile
index 1eb372555d307100182b364e476ee470aa8d99b1..c83412d81c4def38d7073adf0403fd67f456edfa 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,16 @@ include $(TOPDIR)/rules.mk
 ARCH:=arm
 BOARD:=orion
 BOARDNAME:=Marvell Orion
-FEATURES:=squashfs
-SUBTARGETS=generic harddisk
-CFLAGS=-Os -pipe -march=armv5t -mtune=xscale -funit-at-a-time
+FEATURES:=broken
+SUBTARGETS:=generic harddisk
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.34
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="uImage"
+KERNELNAME:=zImage
 
-DEFAULT_PACKAGES += kmod-ath9k wpad-mini
+DEFAULT_PACKAGES += kmod-ath9k kmod-crypto-mv-cesa wpad-mini kmod-i2c-core kmod-i2c-mv64xxx kmod-rtc-isl1208
 
 $(eval $(call BuildTarget))