target: use SPDX license identifiers on Makefiles
[openwrt/staging/stintel.git] / target / linux / pistachio / image / Makefile
index a9c16856a2d6c8c0142837851bc43da1c6b61e2e..7f4e2236c5d2fe34d3551bd25852f5f6d5be4bd6 100644 (file)
@@ -1,9 +1,6 @@
+# SPDX-License-Identifier: GPL-2.0-only
 #
 # Copyright (C) 2017 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
 
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
@@ -11,27 +8,31 @@ include $(INCLUDE_DIR)/image.mk
 KERNEL_LOADADDR := 0x80400000
 
 define Device/Default
-       PROFILES := Default
-       FILESYSTEMS := squashfs
-       KERNEL_DEPENDS = $$(wildcard $$(DTS_DIR)/$$(DEVICE_DTS).dts)
-       KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
-       KERNEL_SUFFIX := -kernel.itb
-       KERNEL_INSTALL := 1
-       KERNEL_IN_UBI := 1
-       IMAGES := factory.ubi sysupgrade.tar
-       IMAGE/factory.ubi := append-ubi
-       IMAGE/sysupgrade.tar := sysupgrade-tar
+  PROFILES := Default
+  FILESYSTEMS := squashfs
+  KERNEL_DEPENDS = $$(wildcard $$(DTS_DIR)/$$(DEVICE_DTS).dts)
+  KERNEL = kernel-bin | gzip | fit gzip $$(DTS_DIR)/$$(DEVICE_DTS).dtb
+  KERNEL_SUFFIX := -kernel.itb
+  KERNEL_INSTALL := 1
+  KERNEL_IN_UBI := 1
+  IMAGES := factory.ubi sysupgrade.tar
+  IMAGE/factory.ubi := append-ubi
+  IMAGE/sysupgrade.tar := sysupgrade-tar
 endef
 
-define Device/marduk
-       DEVICE_DTS := img/pistachio_marduk
-       BLOCKSIZE := 256KiB
-       PAGESIZE := 4KiB
-       DEVICE_TITLE := Creator Ci40
-       DEVICE_PACKAGES := kmod-tpm-i2c-infineon
+define Device/img_creator-ci40
+  DEVICE_VENDOR := Imagination Technologies
+  DEVICE_MODEL := Creator Ci40 (VL-62899)
+  DEVICE_ALT0_VENDOR := Imagination Technologies
+  DEVICE_ALT0_MODEL := Marduk board
+  BOARD_NAME := img,pistachio-marduk
+  DEVICE_DTS := img/pistachio_marduk
+  BLOCKSIZE := 256KiB
+  PAGESIZE := 4KiB
+  DEVICE_PACKAGES := kmod-tpm-i2c-infineon kmod-ca8210 wpan-tools
 endef
 
-TARGET_DEVICES += marduk
+TARGET_DEVICES += img_creator-ci40
 
 
 $(eval $(call BuildImage))