[ppc44x]: upgrade to 3.2, disable ppp by default until we figure out why ppp_generic...
[openwrt/svn-archive/archive.git] / target / linux / ppc44x / Makefile
index 0a5fd353120f97f3e1d79b531ba7fde3f4dd6aed..629eab0361928e12ad2fc61011392a8a8ec8587b 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,18 +8,19 @@ include $(TOPDIR)/rules.mk
 
 ARCH:=powerpc
 BOARD:=ppc44x
-BOARDNAME:=AMCC Taishan
+BOARDNAME:=AMCC/IBM PPC44x
 FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=2.6.24.5
-LINUX_KARCH:=powerpc
+LINUX_VERSION:=3.2.11
 
 include $(INCLUDE_DIR)/target.mk
 
-KERNELNAME:="zImage"
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
 
 define Target/Description
-       Build firmware images for the AMCC Taishan evaluation board
+       Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
 $(eval $(call BuildTarget))