kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
[openwrt/staging/stintel.git] / target / linux / ppc44x / Makefile
index 8f65693dba6d715c5b2547fd3f9463e90fe24825..f6d932743a0b0112862a934ddf70114de1cb0b9c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007-2011 OpenWrt.org
+# Copyright (C) 2007-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,16 +9,20 @@ include $(TOPDIR)/rules.mk
 ARCH:=powerpc
 BOARD:=ppc44x
 BOARDNAME:=AMCC/IBM PPC44x
-FEATURES:=squashfs
-CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
+FEATURES:=squashfs broken
+CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.0.1
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES := $(filter-out ppp%,$(DEFAULT_PACKAGES))
+
 define Target/Description
        Build firmware images for AMCC/IBM PPC44x based boards.
 endef
 
+KERNELNAME:="uImage cuImage.taishan"
+
 $(eval $(call BuildTarget))