Add ps3 target
[openwrt/openwrt.git] / target / linux / ps3 / image / Makefile
diff --git a/target/linux/ps3/image/Makefile b/target/linux/ps3/image/Makefile
new file mode 100644 (file)
index 0000000..e5de265
--- /dev/null
@@ -0,0 +1,18 @@
+#
+# Copyright (C) 2007 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/image.mk
+
+define Image/Prepare
+       cp $(LINUX_DIR)/arch/powerpc/boot/otheros.bld $(KDIR)/image
+endef
+
+define Image/BuildKernel
+       cp $(KDIR)/image $(BIN_DIR)/otheros-$(BOARD)-$(KERNEL).bld
+endef
+
+$(eval $(call BuildImage))