kernel: update linux 3.8 to 3.8.13
[openwrt/openwrt.git] / target / linux / ramips / Makefile
index 206b4ac2a9bdb277dfa92befa0e24c7f9dc59d2c..1214a02ab3580da2bbdf5071eb3bf672fd2e4a34 100644 (file)
@@ -10,16 +10,16 @@ ARCH:=mipsel
 BOARD:=ramips
 BOARDNAME:=Ralink RT288x/RT3xxx
 SUBTARGETS:=rt288x rt305x rt3883
-CFLAGS:=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
-FEATURES:=squashfs
+CFLAGS:=-Os -pipe -fno-caller-saves -mno-branch-likely
+FEATURES:=squashfs gpio
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.8.13
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES+=\
        kmod-leds-gpio kmod-input-core kmod-input-polldev \
        kmod-input-gpio-keys-polled kmod-button-hotplug \
-       kmod-rt2800-pci wpad-mini maccalc
+       kmod-rt2800-pci wpad-mini swconfig
 
 define Target/Description
        Build firmware images for Ralink RT288x/RT3xxx based boards.