ramips: fix partitions and boot for RAVPower RP-WD03
[openwrt/openwrt.git] / target / linux / ramips / image / mt7620.mk
index 149b666aade0ae680aed23fd82240d83b447275d..d9725c9e696fa684a3097e62322da609e3902825 100644 (file)
@@ -488,11 +488,9 @@ define Device/hnet_c108
 endef
 TARGET_DEVICES += hnet_c108
 
-define Device/hootoo_ht-tm05
+define Device/sunvalley_filehub_common
   SOC := mt7620n
   IMAGE_SIZE := 6144k
-  DEVICE_VENDOR := HooToo
-  DEVICE_MODEL := HT-TM05
   DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-i2c-ralink
   LOADER_TYPE := bin
   LOADER_FLASH_OFFS := 0x200000
@@ -505,6 +503,12 @@ define Device/hootoo_ht-tm05
   IMAGE/kernel.bin := append-loader-okli $(1) | check-size 64k
   IMAGE/rootfs.bin := $$(sysupgrade_bin) | check-size
 endef
+
+define Device/hootoo_ht-tm05
+  $(Device/sunvalley_filehub_common)
+  DEVICE_VENDOR := HooToo
+  DEVICE_MODEL := HT-TM05
+endef
 TARGET_DEVICES += hootoo_ht-tm05
 
 define Device/iodata_wn-ac1167gr
@@ -924,14 +928,16 @@ define Device/ralink_mt7620a-v22sg-evb
 endef
 TARGET_DEVICES += ralink_mt7620a-v22sg-evb
 
-define Device/ravpower_wd03
-  SOC := mt7620n
-  IMAGE_SIZE := 7872k
-  DEVICE_VENDOR := Ravpower
-  DEVICE_MODEL := WD03
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci
+define Device/ravpower_rp-wd03
+  $(Device/sunvalley_filehub_common)
+  DEVICE_VENDOR := RAVPower
+  DEVICE_MODEL := RP-WD03
+  SUPPORTED_DEVICES += ravpower,wd03
+  DEVICE_COMPAT_VERSION := 2.0
+  DEVICE_COMPAT_MESSAGE := Partition design has changed compared to older versions (up to 19.07) due to kernel size restrictions. \
+       Upgrade via sysupgrade mechanism is not possible, so new installation via TFTP is required.
 endef
-TARGET_DEVICES += ravpower_wd03
+TARGET_DEVICES += ravpower_rp-wd03
 
 define Device/sanlinking_d240
   SOC := mt7620a